Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Problems Compiling gfortran on mac os-x 10.5.3
From: Chase Latta (chaselatta_at_[hidden])
Date: 2008-03-04 10:16:57


Hello,

I am working with a few other physics students on my campus to try to get open-mpi to run on a cluster of 8 imacs all running mac os-x 10.5.3. Before I start I will let you know that we are not the most savvy programmers so any detailed information would be much appreciated.

We ran the default install of open-mpi and everything installed correctly. We are able to compile and run c programs using the mpicc wrappers. The problem that we are having is that we are unable to get the fortran wrappers to work. We are using gfortran and the compiler works perfectly on its own. To enable the wrapper compilers I ran the command ./configure --enable-f77 --enable-f90 F77=gfortran F90=gfortran. I then ran the make and make install commands. Everything appeared to work correctly. The problem is that when I try to compile a program with mpif90 I get an error saying that open-mpi was not built with fortran 90 support (the same happens with f77). I have looked everywhere in the faq's and cannot figure out why this is happening. The only thing that I can think is that when I tell the F90 wrapper to use gfortran it tells me that there are no flags in my compiler to compiler to compile .f and .f90 files; even though I can compile .f
 and .f90 files with my gfortran compiler. Any help would be very much appreciated.

Thanks in advance,
Chase

      ____________________________________________________________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ