Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] build trouble
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-02-29 16:50:48


Anze --

Sorry for the delay in replying; I've been on travel for 2 weeks.

I tried a few different ways, but I simply cannot reproduce your
error. It looks like you're running something like:

./configure --enable-static ...

And therefore OMPI is building both static and shared libraries, which
causes a different build path (building objects with prefixes and in
subdirectories and the like). However, this works fine for me on my
systems. :-\

If you want both shared and static builds, perhaps try building OMPI
first static (--enable-static and --disable-shared) and then again
shared (no flags necessary; this is the default). Does this work for
you?

On Feb 14, 2008, at 4:27 PM, Anze Slosar wrote:

>
>>
>> On Feb 11, 2008, at 9:59 PM, Anze Slosar wrote:
>>
>>> make[3]: Entering directory
>>> `/group/cosmos/slosar/openmpi-1.2.4/opal/libltdl'
>>> make[3]: *** No rule to make target `lt__strl/home/slosar/util.lo',
>>> needed
>>> by `libltdlc.la'. Stop.
>>
>> That's a very odd error -- I'm assuming /home/slosar is your $HOME.
>>
>
> yes, very odd error, indeed. I attach outputs of configure and make.
> Thanks for any help,
>
> anze
>
>
> <
> config
> .out.gz><make.out.gz>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems