On Thu, 21 Feb 2008, Jeff Squyres wrote:
> While I agree that having AC actually define them to a value is a Good
> Thing (better than just defining it to be empty), I do see the pickle
> that it has put us in. :-\ I don't see an obvious solution.
I do :). Try the attached patch. It sneaks in at the last minute and
defines (for example) both SIZEOF_BOOL and OMPI_SIZEOF_BOOL. mpi.h only
has the define for OMPI_SIZEOF_BOOL. opal_config.h has both, but a note
saying not to use the OMPI_ version. Seems to work.