Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openMPI on 64 bit SUSE 10.2 OS
From: Mark Kosmowski (mark.kosmowski_at_[hidden])
Date: 2008-02-12 17:10:19


 Are you pointing to the 64-bit build of HYPRE? For that matter, like Jeff
asked, are you sure that each library path that you are defining goes to a
64-bit library path?

Good luck,

Mark E. Kosmowski

peiying_at_saturn:~/elmer/elmer-5.4.0/fem-5.4.0> export
> LD_LIBRARY_PATH=/usr/local/openmpi/lib:/usr/local/hypre2.0/lib:$LD_LIBRA
> RY_PATH
> peiying_at_saturn:~/elmer/elmer-5.4.0/fem-5.4.0> ./configure
> --prefix=$ELMER_HOME --with-mpi-dir=$MPI_HOME
> ...

checking for Fortran 77 libraries of mpif90...
> -L/usr/local/hypre2.0/lib -L/usr/local/lib
> -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../.. -lHYPRE -lmpi_f90
> checking for Fortran libraries of mpif90... -L/usr/local/hypre2.0/lib
> -L/usr/local/lib -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2
> -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../lib64
> -L/lib/../lib64 -L/usr/lib/../lib64
> -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../x86_64-suse-linux/l
> ib -L/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../.. -lHYPRE -lmpi_f90
> checking for dseupd_ in -larpack... yes
> checking for pdneupd_ in -lparpack... no
> configure: WARNING: No parallel arpack found.
> checking for HYPRE_IJMatrixCreate in -lHYPRE... no
> configure: WARNING: HYPRE not found, some functionaly will be disabled.
> checking for umf4def_ in -lumfpack... yes
> checking for mtc_init in -lmatc... yes
> checking for main in -lm... yes
> configure: error: The MPI version needs parpack. Disabling MPI.
> peiying_at_saturn:~/elmer/elmer-5.4.0/fem-5.4.0>
>
>
> -------------------------------------
> Pei-Ying Hsieh, Ph.D.
> Staff Product Engineer
> Siemens Healthcare Diagnostics Inc.
> 511 Benedict Ave., MS 32
> Tarrytown, NY 10591
> USA
> Phone: (914)524-3146
> fax: (914)524-2580
> email: Pei-Ying.Hsieh_at_[hidden]
> www.siemens.com/diagnostics
>
>
> What puzzles me is that, on 32 bit OpenSUSE, I was able to compile elmer
> solver without any issue using the same script. I am planning to use
> HYPRE library, but, configure file indicated that it cannot find hypre
> either which is another puzzle to me. I will look into this further.
>
> Best,
>
> pei
>
>
> Is it possible that this could be a problem with /usr/lib64 as opposed
> to /usr/lib?
>
> Just a thought...
>
> Jeff F. Pummill
> Senior Linux Cluster Administrator
> University of Arkansas
> //
>
>
>