Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] A beginer's question
From: Hsieh, Pei-Ying (MED US) (pei-ying.hsieh_at_[hidden])
Date: 2008-02-08 16:12:15


Thanks a lot Aurelien!

I am able to compile and run a test hello_mpi.c code successfully now.

Best,

Pei

-----Original Message-----
From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On Behalf Of Aurélien Bouteiller
Sent: Friday, February 08, 2008 2:38 PM
To: Open MPI Users
Subject: Re: [OMPI users] A beginer's question

Hi,

You have to update the ldcache each time you add some .so files to the
directories it refers to. If you don't, any .so file you added since
system bootup will not be found (even if they are in the filesystem).
This is made by running ldconfig as root. If this does not solve your
problem, please check that /usr/local/lib appears in the output of
ldconfig -p.

If it does not, you have to add this directory to /etc/ld.so.conf, or
to the LD_LIBRARY_PATH shell variable, or to use the --enable-mpirun-
prefix-by-default option in the Open MPI configure.

Hope that helps,
Aurelien

Le 8 févr. 08 à 14:28, Hsieh, Pei-Ying (MED US) a écrit :

>
> Dear OpenMPI group:
>
> I am sorry about this newbie question, but, I was not able to find the
> answer so far.
>
> I compiled OpenMPI-1.2.5 from source on a OpenSUSE 10.3 64 bit OS.
> Configure and installation seemed fine (using prefix=/usr/local). I
> installed openmpi as root. But, when I ran a quick test program, I
> got
> the following error:
>
> saturn:~/openmpi/openmpi-1.2.5 # mpicc -o hello_mpi.c hello_mpi.c
> mpicc: error while loading shared libraries: libopen-pal.so.0: cannot
> open shared object file: No such file or directory
> saturn:~/openmpi/openmpi-1.2.5 #
>
> But, I found libopen-pal.so.0 in /usr/local/lib. How to get
> mpicc/mpif90 wraper to find libopen-pal.so in the correct directoy?
>
> Also, on another workstation (OpenSUSE 10.2 64 bit OS), I installed
> the
> openmpi-1.2.2 rpm (and openmpi-1.2.2-devel rpm). Libopen-pal.so was
> laced in /usr/lib64/mpi/gcc/openmpi/lib64. I has the same problem
> when
> executing mpicc/mpif90.
>
> Can someone shed some light on this? Thanks!
>
> Pei
> -------------------------------------
> Pei-Ying Hsieh, Ph.D.
> Staff Product Engineer
> Siemens Healthcare Diagnostics Inc.
> 511 Benedict Ave., MS 32
> Tarrytown, NY 10591
> USA
> Phone: (914)524-3146
> fax: (914)524-2580
> email: Pei-Ying.Hsieh_at_[hidden]
> www.siemens.com/diagnostics
>
> ----------------------------------------------------------------------------
> This message and any included attachments are from Siemens Medical
> Solutions
> and are intended only for the addressee(s).
> The information contained herein may include trade secrets or
> privileged or
> otherwise confidential information. Unauthorized review, forwarding,
> printing,
> copying, distributing, or using such information is strictly
> prohibited and may
> be unlawful. If you received this message in error, or have reason
> to believe
> you are not authorized to receive it, please promptly delete this
> message and
> notify the sender by e-mail with a copy to Central.SecurityOffice_at_[hidden]
>
> Thank you
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

--
Dr. Aurélien Bouteiller
Sr. Research Associate - Innovative Computing Laboratory
Suite 350, 1122 Volunteer Boulevard
Knoxville, TN 37996
865 974 6321
_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users