Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun, paths and xterm again
From: jody (jody.xha_at_[hidden])
Date: 2008-02-05 12:02:44


Hi Tim

> Your desktop is plankton, and you want
> to run a job on both plankton and nano, and have xterms show up on nano.

Not on nano, but on plankton, but ithink this was just a typo :)

> It looks like you are already doing this, but to make sure, the way I
> would use xhost is:
> plankton$ xhost +nano_00
> plankton$ mpirun -np 4 --hostfile testhosts -x DISPLAY=plankton:0.0
> xterm -hold -e ../MPITest
This gives me 2 lines of
  xterm Xt error: Can't open display: plankton:0.0

>
> Can you try running:
> plankton$ mpirun -np 1 -host nano_00 -x DISPLAY=plankton:0.0 printenv
This yields
DISPLAY=plankton:0.0
OMPI_MCA_orte_precondition_transports=4a0f9ccb4c13cd0e-6255330fbb0289f9
OMPI_MCA_rds=proxy
OMPI_MCA_ras=proxy
OMPI_MCA_rmaps=proxy
OMPI_MCA_pls=proxy
OMPI_MCA_rmgr=proxy
SHELL=/bin/bash
SSH_CLIENT=130.60.49.141 59524 22
USER=jody
LD_LIBRARY_PATH=/opt/openmpi/lib
SSH_AUTH_SOCK=/tmp/ssh-enOzt24653/agent.24653
MAIL=/var/mail/jody
PATH=/opt/openmpi/bin:/usr/local/bin:/bin:/usr/bin
PWD=/home/jody
SHLVL=1
HOME=/home/jody
LOGNAME=jody
SSH_CONNECTION=130.60.49.141 59524 130.60.49.128 22
_=/opt/openmpi/bin/orted
OMPI_MCA_mpi_yield_when_idle=0
OMPI_MCA_mpi_paffinity_processor=0
OMPI_MCA_universe=jody_at_[hidden]:default-universe-10265
OMPI_MCA_ns_replica_uri=0.0.0;tcp://130.60.49.141:50310
OMPI_MCA_gpr_replica_uri=0.0.0;tcp://130.60.49.141:50310
OMPI_MCA_orte_app_num=0
OMPI_MCA_orte_base_nodename=nano_00
OMPI_MCA_ns_nds=env
OMPI_MCA_ns_nds_cellid=0
OMPI_MCA_ns_nds_jobid=1
OMPI_MCA_ns_nds_vpid=0
OMPI_MCA_ns_nds_vpid_start=0
OMPI_MCA_ns_nds_num_procs=1

>
> just to make sure the environment variable is being properly set.
>
> You might also try:
> in terminal 1:
> plankton$ xhost +nano_00
>
> in terminal 2:
> plankton$ ssh -x nano_00
> nano_00$ export DISPLAY="plankton:0.0"
> nano_00$ xterm
>
This experiment also gives
xterm Xt error: Can't open display: plankton:0.0

> This will ssh into nano, disabling ssh X forwarding, and try to launch
> an xterm. If this does not work, then something is wrong with your x
> setup. If it does work, it should work with Open MPI as well.
>
So i guess something is wrong with my X setup.
I wonder what it could be ...
Doing the same with X11 forwarding works perfectly.
But why is X11 forwarding bad? Or differently asked,
does Opem MPI make the ssh connection in such a way
that X11 forwarding is disabled?

Thank YOu
  Jody