Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun, paths and xterm again
From: Tim Prins (tprins_at_[hidden])
Date: 2008-02-05 11:36:27


Hi Jody,

Just to make sure I understand. Your desktop is plankton, and you want
to run a job on both plankton and nano, and have xterms show up on nano.

It looks like you are already doing this, but to make sure, the way I
would use xhost is:
plankton$ xhost +nano_00
plankton$ mpirun -np 4 --hostfile testhosts -x DISPLAY=plankton:0.0
xterm -hold -e ../MPITest

Can you try running:
plankton$ mpirun -np 1 -host nano_00 -x DISPLAY=plankton:0.0 printenv

just to make sure the environment variable is being properly set.

You might also try:
in terminal 1:
plankton$ xhost +nano_00

in terminal 2:
plankton$ ssh -x nano_00
nano_00$ export DISPLAY="plankton:0.0"
nano_00$ xterm

This will ssh into nano, disabling ssh X forwarding, and try to launch
an xterm. If this does not work, then something is wrong with your x
setup. If it does work, it should work with Open MPI as well.

For your second question: I'm not sure why there would be a difference
in finding the shared libraries in gdb vs. with the xterm.

Tim

jody wrote:
> Hi
> Sorry to bring this subject up again -
> but i have a problem getting xterms
> running for all of my processes (for debugging purposes).
> There are actually two problem involved:
> display, and paths.
>
>
> my ssh is set up so that X forwarding is allowed,
> and, indeed,
> ssh nano_00 xterm
> opens an xterm from the remote machine nano_00.
>
> When i run my program normally, it works ok:
> [jody]:/mnt/data1/neander:$mpirun -np 4 --hostfile testhosts ./MPITest
> [aim-plankton.unizh.ch]I am #0/4 global
> [aim-plankton.unizh.ch]I am #1/4 global
> [aim-nano_00]I am #2/4 global
> [aim-nano_00]I am #3/4 global
>
> But when i try to see it in xterms
> [jody]:/mnt/data1/neander:$mpirun -np 4 --hostfile testhosts -x
> DISPLAY xterm -hold -e ./MPITest
> xterm Xt error: Can't open display: :0.0
> xterm Xt error: Can't open display: :0.0
>
> (same happens, if i set DISPLAY=plankton:0.0, or if i use plankton's
> ip address;
> and xhost is enabled for nano_00)
>
> the other two (the "local") xterms open, but they display the message:
> ./MPITest: error while loading shared libraries: libmpi_cxx.so.0:
> cannot open shared object file: No such file or directory
> (This also happens if i only have local processes)
>
> So my first question is: what do i do to enable nano_00 to display an xterm
> on plankton? Using normal ssh there seems to be no problem.
>
> Second question: why does the use of xterm "hide" the open-mpi libs?
> Interestingly: if i use xterm with gdb to start my application, it works.
>
> Any ideas?
>
> Thank you
> Jody
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users