Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Help: Trouble building OpenMPI v1.2.4 with PGI v7.0-6
From: Adam Moody (moody20_at_[hidden])
Date: 2008-01-31 19:01:29


Here is some more info. The build works if I do either of:

(1) Build with PGI v7.1-3 instead of PGI v7.0-3
(2) Or, drop the "-g" option in CXXFLAGS, i.e.,
change:
    CXXFLAGS="-Msignextend -g -O2"
to just:
    CXXFLAGS="-Msignextend -O2"

I'd still like to know if there is a better fix (I need a 7.0-3 build
and would prefer to have -g set). Anyone know a better fix?
Thanks again,
-Adam

Adam Moody wrote:

>Hello,
>I'm trying to build OpenMPI v1.2.4 with the PGI v7.0-6 compilers on an
>Opteron cluster. It fails during the configure trying to check the size
>of a boolean datatype. I've included details below.
>
>Anyone know how to resolve this problem?
>Thanks,
>-Adam Moody
>MPI Support
>Lawrence Livermore National Laboratory
>
>
>I'm building with the 7.0-6 version of the PGI compilers on Opteron:
>
> >>: pgcc -V
>
> pgcc 7.0-6 64-bit target on x86-64 Linux
> Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
> Copyright 2000-2007, STMicroelectronics, Inc. All Rights Reserved.
>
>Here is the environment and configure line:
>
> export CC=pgcc
> export CXX=pgCC
> export F77=pgf77
> export FC=pgf90
> export CFLAGS="-Msignextend -g -O2"
> export CXXFLAGS="-Msignextend -g -O2"
> export FFLAGS="-g -O2"
> export FCFLAGAS="-g -O2"
> export PGI_PATH="/usr/local/tools/pgi-7.0.6/bin" # this was
>necessary to get the PGI to build
> export LD_LIBRARY_PATH="/usr/local/tools/pgi-7.0.6/lib" # this was
>necessary to get the PGI to build
> export PATH="$PGI_PATH:$PATH"
> export CONFIG_FLAGS="--with-wrapper-cflags='-Msignextend'
>--with-wrapper-cxxflags='-Msignextend'"
> PREFIX=${ROOT}/pgi
>
> ./configure --prefix=$PREFIX $CONFIG_FLAGS --enable-mpi-f77
>--enable-mpi-f90 --disable-heterogeneous --with-openib=/usr
>
>The configure fails with this message:
>
> checking for bool... yes
> checking size of bool... configure: error: cannot compute sizeof (bool)
> See `config.log' for more details.
>
>Looking in config.log, this is what I see:
>
> configure:23445: checking size of bool
> configure:23747: pgCC -o conftest -DNDEBUG -Msignextend -g -O2
>conftest.cpp >&5
> "conftest.cpp", line 157: warning: statement is unreachable
> return 0;
> ^
>
> /var/tmp/moody20/pgCCw95dctdp-LtG.o:(.debug_info+0xd1e): undefined
>reference to `.LB822'
> /var/tmp/moody20/pgCCw95dctdp-LtG.o:(.debug_info+0xd26): undefined
>reference to `.LB828'
> /var/tmp/moody20/pgCCw95dctdp-LtG.o:(.debug_info+0xd3c): undefined
>reference to `.LB832'
> /var/tmp/moody20/pgCCw95dctdp-LtG.o:(.debug_info+0xd44): undefined
>reference to `.LB837'
> configure:23750: $? = 2
> configure: program exited with status 2
> configure: failed program was:
>_______________________________________________
>users mailing list
>users_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>