Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Occasional mpirun hang on completion
From: Barry Rountree (rountree_at_[hidden])
Date: 2008-01-25 14:56:43


On Thu, Jan 24, 2008 at 10:09:51PM -0500, Barry Rountree wrote:
> On Thu, Jan 24, 2008 at 04:03:49PM -0500, Tim Mattox wrote:
> > Hello Barry,
> > I am guessing you are trying to use a threaded build of Open MPI...
> >
> > Unfortunately, the threading support in Open MPI 1.2.x is not only not well
> > tested, it has many known problems. We do not advise use of threading in
> > the Open MPI 1.2.x series. We even added a warning in version 1.2.5 if
> > you try to use threading... specifically we added run-time warnings during
> > MPI_INIT when MPI_THREAD_MULTIPLE and/or progression threads are used.
> >
> > We are targeting the 1.3 series to have threading support actually working.
>
> Well, I'm happy the problem is obvious and the workaround is easy. I'll
> compile that version tonight and try it out when I get some time on the
> cluster tomorrow.

That fixed it.

Barry

>
> Thanks for the help!
>
> Barry
>