Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Tracing the library using gdb and xterm
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-01-03 11:32:57


Per my previous mail, Open MPI (by default) closes its ssh sessions
after the remote processes are launched, so X forwarding through ssh
will not work.

If it is possible (and I think it is, based on your subsequent
replies), you might be best served with unencrypted X forwarding.

On Jan 3, 2008, at 11:02 AM, Doug Reeder wrote:

> Krishna,
>
> Review the ssh and sshd man pages. When using ssh -X it takes care
> of defining the DISPLAY and sending the X11 images to your screen.
> Defining DISPLY directly generally won't work (that is how you do it
> with rlogin but not with ssh).
>
> Doug Reeder
> On Jan 3, 2008, at 1:54 AM, Krishna Chaitanya wrote:
>
>> Hi Rolf,
>> Thanks for that. There is still one minor problem,
>> though. The xwindow is getting spawned on the remote machine and
>> not on my local machine. It now looks like,
>> mpirun --prefix /usr/local -hostfile machines -x DISPLAY -x PATH -
>> np 2 xterm -e gdb peruse_ex1
>> Please let me know what i can do to have it displayed
>> on my machine. I have the DISPLAY variable set to 0.0 on both the
>> machines and I am ssh-ing into the other machine by using the -X
>> switch.
>>
>> Thanks,
>> Krishna Chaitanya
>>
>>
>> On 1/2/08, Rolf Vandevaart <Rolf.Vandevaart_at_[hidden]> wrote: Krishna
>> Chaitanya wrote:
>> > Hi,
>> > I have been tracing the interactions between the
>> PERUSE
>> > and MPI library,on one machine. I have been using gdb along with
>> xterm
>> > to have two windows open at the same time as I step through the
>> code. I
>> > wish to get a better glimpse of the working of the point to point
>> calls,
>> > by launching the job on two machines and by tracing the flow in a
>> > similar manner. This is where I stand as of now :
>> >
>> > mpirun --prefix /usr/local -hostfile machines -np 2 xterm -e gdb
>> peruse_ex1
>> > xterm Xt error: Can't open display:
>> > xterm: DISPLAY is not set
>> >
>> > I tried using the display option for xterm and
>> setting
>> > the value as 0.0, that was not of much help.
>> > If someone can guide me as to where the DISPLAY
>> parameter
>> > has to be set to allow the remote machine to open the xterm
>> window, it
>> > will be of great help.
>> >
>> > Thanks,
>> > Krishna
>> >
>>
>> I also do the the following:
>>
>> -x DISPLAY -x PATH
>>
>> In this way, both your DISPLAY and PATH settings make it to the
>> remote node.
>>
>> Rolf
>> --
>>
>> =========================
>> rolf.vandevaart_at_[hidden]
>> 781-442-3043
>> =========================
>>
>>
>>
>> --
>> In the middle of difficulty, lies opportunity
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems