Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] No output from mpirun
From: Reuti (reuti_at_[hidden])
Date: 2007-12-30 17:45:28


Hi,

Am 26.12.2007 um 10:08 schrieb Varun R:

> I just installed Openmpi 1.2.2 on my new openSUSE 10.3 system. All
> my programs(C++) compile well with 'mpic++' but when I run them
> with 'mpirun' i get no output and I immediately get back the
> prompt. I tried the options '--verbose' and got nothing. When I
> tried '--debug-daemons' I get the following output:
>
> Daemon [0,0,1] checking in as pid 6308 on host suse-nigen
> [suse-nigen:06308] [0,0,1] orted: received launch callback
> [suse-nigen:06308] [0,0,1] orted_recv_pls: received message from
> [0,0,0]
> [suse-nigen:06308] [0,0,1] orted_recv_pls: received exit
>
>
> Also when I simply run the executable without mpirun it gives the
> right output. I also tried inserting a long 'for' loop in the
> program to check if it's getting executed at all and as I suspected
> mpirun still returns immediately to the prompt. Here's my program:

is the mpirun the one from Open MPI?

-- Reuti

> #include <iostream>
> #include <mpi.h>
>
> using namespace std;
>
> int main(int argc,char* argv[])
> {
> int rank,nproc;
> cout<<"Before"<<endl;
>
> MPI_Init(&argc,&argv);
> MPI_Comm_rank(MPI_COMM_WORLD,&rank);
> MPI_Comm_size(MPI_COMM_WORLD,&nproc);
> cout<<"Middle"<<endl;
> MPI_Finalize();
>
> int a = 5;
> for(int i=0; i< 100000; i++)
> for(int j=0; j<10000; j++)
> a += 4;
>
> if(rank == 0)
> cout<<"Rank 0"<<endl;
>
> cout<<"Over"<<a<<endl;
>
> return 0;
> }
>
> I also tried version 1.2.4 but still no luck. Could someone please
> tell me what could be wrong here?
>
> Thanks,
> Varun
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users