Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] new to MPI+infiniband
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-12-19 08:55:48


In general, you need a functioning IB subsystem on your machines for
OMPI to build for and use IB. This includes both the set of kernel
drivers and the userspace libraries. In particular, Open MPI v1.2
uses the "ibverbs" library. If OMPI can find the ibverbs library and
headers during its configure phase, it will build IB support and try
to use it at run time.

You can see if OMPI finds what it needs in the stdout of configure --
search for the string "openib" and see where it configures the BTL
openib component. If it ends with a message indicating that it will
compile the openib BTL component, then you're good. If not, you'll
see some specific tests that fail that indicate why it won't include
that support (e.g., can't find the right header files or somesuch).

On Dec 19, 2007, at 8:49 AM, pat.o'bryant_at_[hidden] wrote:

> Brian,
> Here is how I do it:
>
> ./configure --prefix /opt/openmpi-1.2.4 --with-openib=/usr/local/
> ofed \
> --without-tm CC=icc CXX=icpc F77=ifort FC=ifort \
> --with-threads=posix --enable-mpi-threads
>
>
> J.W. (Pat) O'Bryant,Jr.
> Business Line Infrastructure
> Technical Systems, HPC
> Office: 713-431-7022
>
>
>
>
> "Brian Budge"
> <brian.budge_at_g
>
> mail.com> To
> Sent by: "Open MPI Users"
> users-bounces@ <users_at_[hidden]>
> open-
> mpi.org cc
>
>
> Subject
> 12/19/07 12:35 [OMPI users] new to MPI
> +infiniband
> AM
>
>
> Please respond
> to
> Open MPI Users
> <users_at_open-mp
> i.org>
>
>
>
>
>
>
>
>
> Hi all -
>
> I have been using OpenMPI for quite a while now, and its working out
> great.
> I was looking at the FAQ and trying to figure out how to configure
> OpenMPI
> with infiniband. It shows how to enable IB pointing to the OFED
> directory.
>
>
> I have infiniband built into the kernel, along with IP over IB and
> with the
> Mellanox drivers. What would I still need to install, and how would I
> configure OpenMPI to work with this?
>
> Thanks,
> Brian_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems