Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Compiling 1.2.4 using Intel Compiler 10.1.007 on Leopard
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-12-14 10:47:27


Warner --

I have seen on other lists that Intel has v10.1.011 out -- although I
don't know if this is on OS X or Linux or both.

Could you check to see if you have the latest version of the 10.1
compiler?

On Dec 13, 2007, at 9:06 AM, Jeff Squyres wrote:

> On Dec 12, 2007, at 1:18 PM, Warner Yuen wrote:
>
>> It seems that the problems are partially the compilers fault, maybe
>> the updated compilers didn't catch all the problems filed against
>> the last release? Why else would I need to add the "-no-multibyte-
>> chars" flag for pretty much everything that I build with ICC? Also,
>> its odd that I have to use /lib/cpp when using Intel ICC/ICPC
>> whereas with GCC things just find their way correctly. Again, IFORT
>> and GCC together seem fine.
>
> I'm afraid that I'm not enough of an OS X expert to know the answers
> to these questions... :-(
>
>> Lastly... not that I use these... but MPICH-2.1 and MPICH-1.2.7 for
>> Myrinet built just fine.
>>
>> Here are the output files:
>
> I actually didn't see the error in there -- did you grab stdout and
> stderr when building?
>
> --
> Jeff Squyres
> Cisco Systems
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems