Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Compiling 1.2.4 using Intel Compiler 10.1.007 on Leopard
From: Warner Yuen (wyuen_at_[hidden])
Date: 2007-12-12 13:18:26


Hi Jeff,

It seems that the problems are partially the compilers fault, maybe
the updated compilers didn't catch all the problems filed against the
last release? Why else would I need to add the "-no-multibyte-chars"
flag for pretty much everything that I build with ICC? Also, its odd
that I have to use /lib/cpp when using Intel ICC/ICPC whereas with GCC
things just find their way correctly. Again, IFORT and GCC together
seem fine. Lastly... not that I use these... but MPICH-2.1 and
MPICH-1.2.7 for Myrinet built just fine.

Here are the output files:

Warner Yuen
Scientific Computing Consultant
Apple Computer
email: wyuen_at_[hidden]
Tel: 408.718.2859
Fax: 408.715.0133

On Dec 12, 2007, at 9:00 AM, users-request_at_[hidden] wrote:

> ----------------------------------------------------------------------
>
> Message: 1
> Date: Wed, 12 Dec 2007 06:50:03 -0500
> From: Jeff Squyres <jsquyres_at_[hidden]>
> Subject: Re: [OMPI users] Problems compiling 1.2.4 using Intel
> Compiler 10.1.006 on Leopard
> To: Open MPI Users <users_at_[hidden]>
> Message-ID: <43BB0BCE-E328-4D3E-AE61-84991B27FBE9_at_[hidden]>
> Content-Type: text/plain; charset=US-ASCII; format=flowed; delsp=yes
>
> My primary work platform is a MacBook Pro, but I don't specifically
> develop for OS X, so I don't have any special compilers.
>
> Sorry to ask this because I think the information was sent before, but
> could you send all the compile/failure information? http://www.open-mpi.org/community/help/
>