Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Configure fails with icc 10.1.008
From: de Almeida, Valmor F. (dealmeidav_at_[hidden])
Date: 2007-12-07 21:51:12


Eric,

I see you are using a gentoo distro like me. My version uses the vanilla
kernel 2.6.22.9 and gcc-4.1.2. I have the following intel compiler
versions installed:

10.0.026 10.1.008 10.1.011 9.1.052

None of them are able to build a functional version of openmpi-1.2.4.
I've been posting this problem to this list and also to the Intel
premier customer support. The actual problem is that after building
openmpi, I get:

->ompi_info
Segmentation fault

->mpic++ --showme
Segmentation fault

The compilers do work outside openmpi. I can compile and run non-mpi
programs.

Please post to this list whether you are able to compile and get a
working openmpi with gcc-4.1 series.

Thanks,

--
Valmor
> -----Original Message-----
> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]]
On
> Behalf Of Eric Thibodeau
> Sent: Friday, December 07, 2007 11:14 AM
> To: Jeff Squyres
> Cc: Open MPI Users
> Subject: Re: [OMPI users] Configure fails with icc 10.1.008
> 
> Jeff,
> 
>     Thanks...at 23h30 coffee is far off... I saw the proper section of
> the config.log showing exactly that (hello world not working). For
> everyone else's benefit, ICC (up to 10.1.008) is _not_ compatible with
> GCC 4.2... (guess I'll have to retro back to 4.1 series...)
> 
> Eric
> 
> Jeff Squyres wrote:
> > This is not an Open MPI problem; Open MPI is simply reporting that
> > your C++ compiler is not working.  OMPI tests a trivial C++ program
> > that uses the STL to ensure that your C++ program is working.  It's
> > essentially:
> >
> > #include <string>
> > int
> > main ()
> > {
> > std::string foo = "Hello, world"
> >   ;
> >   return 0;
> > }
> >
> > You should probably check with Intel support for more details.
> >
> >
> >
> > On Dec 6, 2007, at 11:25 PM, Eric Thibodeau wrote:
> >
> >> Hello all,
> >>
> >>   I am unable to get past ./configure as ICC fails on C++ tests
(see
> >> attached ompi-output.tar.gz). Configure was called without and the
> >> with sourcing `/opt/intel/cc/10.1.xxx/bin/iccvars.sh`  as per one
of
> >> the invocation options in icc's doc. I was unable to find the
> >> relevant (well..intelligible for me that is ;P ) cause of the
failure
> >> in config.log. Any help would be appreciated.
> >>
> >> Thanks,
> >>
> >> Eric Thibodeau
> >> <ompi-output.tar.gz>_______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> >
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users