Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMP + OpenMPI
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-12-06 09:42:37


Wow, that's quite a .sig. :-)

Open MPI will automatically stripe large messages across however many
NICs you have. So you shouldn't need to use multiple threads.

The threading support in the OMPI v1.2 series is broken; it's not
worth using. There's a big warning in configure when you enable it. :-)

On Dec 5, 2007, at 9:57 PM, Tee Wen Kai wrote:

> Hi everyone,
>
> I have installed openmpi-1.2.3. My system has two ethernet ports.
> Thus, I am trying to make use of both ports to speed up the
> communication process by using openmp to split into two threads.
> However, this implementation always cause error. Then I realized
> that I need to build openmpi using --enable-mpi-threads and use
> MPI_Init_thread to initialize. But, the initialization always return
> MPI_THREAD_SINGLE no matter what value I set. Using ompi_info|grep
> Thread, it shows that thread support has already been activated.
> Thus, I seek your help to teach me what other configurations I need
> to set in order to use multi-threads and what are the parameters to
> include in mpirun in order to use the two ethernet ports.
>
> Thank you very much.
>
> Regards,
> Tee
>
>
>
> _________________________________________________
>
>
>
> Many of us spend our time wishing for things we could have if we
> didn't spend half our time wishing.
>
> Looking for last minute shopping deals? Find them fast with Yahoo!
> Search._______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems