Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] suggested intel compiler version for openmpi-1.2.4
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-12-06 09:08:50


If Intel is telling you that they don't support your glibc version, I
wouldn't be surprised by random segv's in any application that you
build on that platform (including Open MPI).

On Dec 5, 2007, at 9:59 AM, de Almeida, Valmor F. wrote:

>
>
> Attached is the config.log file for intel 9.1.052. I've also tried the
> intel 10.1.008 and posted to this list the config.log on a previous
> e-mail (12/2/2007).
>
> Here are the key commands for building and installing
>
> export FC=ifort
> export F77=ifort
> export CXX=icpc
> export CC=icc
>
> ./configure --prefix=/usr/local/packages/openmpi-1.2.4_intel-9.1.052
> --with-mpi-param_check=always --with-mpi-f90-size=medium
> --with-f90-max-array-dim=4 CC=icc CXX=icpc F90=ifort F77=ifort
>
> make -j 2
> make -j 2 install
>
> Here is some info on my system
>
> ->emerge --info
> Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0,
> 2.6.22.9 i686)
> =================================================================
> System uname: 2.6.22.9 i686 Intel(R) Xeon(TM) CPU 2.66GHz
> Timestamp of tree: Sat, 17 Nov 2007 04:30:01 +0000
> app-shells/bash: 3.2_p17
> dev-java/java-config: 1.3.7, 2.0.33-r1
> dev-lang/python: 2.4.4-r6
> dev-python/pycrypto: 2.0.1-r6
> sys-apps/baselayout: 1.12.9-r2
> sys-apps/sandbox: 1.2.18.1-r2
> sys-devel/autoconf: 2.13, 2.61-r1
> sys-devel/automake: 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
> sys-devel/binutils: 2.18-r1
> sys-devel/gcc-config: 1.3.16
> sys-devel/libtool: 1.5.24
> virtual/os-headers: 2.6.22-r2
>
> Here is
>
> ->echo $PATH
> /opt/cubit:/opt/gambit/bin:/opt/compilers/intel/idb/9.1.052/bin:/opt/
> com
> pilers/intel/fc/9.1.052/bin:/opt/compilers/intel/cc/9.1.052/bin:/usr/
> loc
> al/nwchem/bin:/usr/local/visit/bin:/usr/local/ompi_intel/bin:/usr/
> local/
> sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-
> pc-
> linux-gnu/gcc-bin/4.1.2:/usr/local/packages/cca-
> tools-0.6.4_gcc-4.1.2/bi
> n:/usr/bin:/opt/chpl/bin/linux
>
> Here is
>
> ->echo $LD_LIBRARY_PATH
> /opt/compilers/intel/fc/9.1.052/lib:/opt/compilers/intel/cc/9.1.052/
> lib:
> /usr/local/ompi_intel/lib::/usr/local/packages/cca-
> tools-0.6.4_gcc-4.1.2
> /lib
>
>
> I am also copying this to the person at Intel who is looking at the
> problem, and here is a posting from the Intel Premier Support (Issue
> number: 461117) for this case
>
>
> 12/04/2007
> Valmor,
> Thanks for your submission. The Intel compilers have supported the 2.6
> Linux kernel for some time now, but they do not yet support glibc 2.6.
> The most recent version of glibc supported is 2.5, as represented by
> the
> Red Hat Enterprise Linux 5 and Ubuntu 7.04 distributions. There are
> known issues with Ubuntu 7.10, for example, which has a later glibc.
> What version of Gentoo are you using, and do you have the option to
> try
> an older glibc and gcc along with the Intel compiler version 10.1?
>
> It's not sure that the glibc version is the problem, so I will try to
> build OpenMPI with glibc 2.5 on Red Hat EL5 or Ubuntu 7.04 to see if
> that shows any problems.
>
> Regards,
> Martyn
>
> 12/05/2007
> Martyn,
>
> During the installation of 10.1.008, the install script says that
> glibc
> 2.6 is supported.
>
> --
> Valmor
>
>
> Thanks for your help.
>
> --
> Valmor
>
>
>
>
>
>
>
>
>> -----Original Message-----
>> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]]
> On
>> Behalf Of Jeff Squyres
>> Sent: Tuesday, December 04, 2007 5:58 PM
>> To: Open MPI Users
>> Subject: Re: [OMPI users] suggested intel compiler version for
> openmpi-
>> 1.2.4
>>
>> I have compiled Open MPI with Intel 10.0 and 9.1 with no problems on
>> RHEL4U4.
>>
>> Can you send all the info that you can (obviously, ompi_info won't
>> run) from http://www.open-mpi.org/community/help/ ?
>>
>>
>>
>> On Dec 4, 2007, at 4:26 PM, de Almeida, Valmor F. wrote:
>>
>>>
>>> Hello,
>>>
>>> What is the suggested intel compiler version to compile
> openmpi-1.2.4?
>>>
>>> I tried versions 10.1.008 and 9.1.052 and no luck in getting a
> working
>>> library. In both cases I get:
>>>
>>> ->mpic++ --showme
>>> Segmentation fault
>>>
>>> ->ompi_info
>>> Segmentation fault
>>>
>>> Thanks for your help.
>>>
>>> --
>>> Valmor de Almeida
>>>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> --
>> Jeff Squyres
>> Cisco Systems
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
> <config.log.bz2>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems