Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Segmentation fault: intel 10.1.008 compilers w/ openmpi-1.2.4
From: Åke Sandgren (ake.sandgren_at_[hidden])
Date: 2007-12-04 06:18:10


On Tue, 2007-12-04 at 09:33 +0100, Åke Sandgren wrote:
> On Sun, 2007-12-02 at 21:27 -0500, de Almeida, Valmor F. wrote:
> > Hello,
> >
> > After compiling ompi-1.2.4 with the intel compiler suite 10.1.008, I get
> >
> > ->mpicxx --showme
> > Segmentation fault
> >
> > ->ompi_info
> > Segmentation fault
> >
> > The 10.1.008 is the only one I know that officially supports the linux
> > kernel 2.6 and glibc-2.6 that I have on my system.
> >
> > config.log file attached.
> >
> > Any help appreciated.
>
> Run an nm on opal/mca/memory/ptmalloc2/.libs/malloc.o and check if
> malloc is defined in there.
>
> This seems to be the problem i have when compiling with pathscale.
> It removes the malloc (public_mALLOc) function from the objectfile but
> leaves the free (public_fREe) in there, resulting in malloc/free
> mismatch.

For pathscale the solution for me was to add -fno-builtin.
Now ompi_info doesn't segfault anymore.

Check if the intel 10 has something similar.

-- 
Ake Sandgren, HPC2N, Umea University, S-90187 Umea, Sweden
Internet: ake_at_[hidden]   Phone: +46 90 7866134 Fax: +46 90 7866126
Mobile: +46 70 7716134 WWW: http://www.hpc2n.umu.se