Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Newbie: Using hostfile
From: Madireddy Samuel Vijaykumar (mad.vijay_at_[hidden])
Date: 2007-11-29 02:09:20


A non MPI application does run without any issues. Could eloberate on
what you mean by doing mpirun "hostname". You mean i just do an
'mpirun lynx' in my case???

On Nov 28, 2007 9:57 PM, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> Well, that's odd.
>
> What happens if you try to mpirun "hostname" (i.e., a non-MPI
> application)? Does it run, or does it hang?
>
>
>
> On Nov 23, 2007, at 6:00 AM, Madireddy Samuel Vijaykumar wrote:
>
> > I have been using using clusters for some tests. My localhost "lynx"
> > and i have "puma" and "tiger" which make up the cluster. All have
> > passwordless ssh enabled. Now if i have the following in my
> > hostfile(perline in the same order)
> >
> > lynx
> > puma
> > tiger
> >
> > My tests(from lynx) run over the cluster without any issues.
> >
> > But if move/remove the lynx from there either (perline in the same
> > order)
> >
> > puma
> > lynx
> > tiger
> >
> > or
> >
> > puma
> > tiger
> >
> > My test(from lynx) just does not get any where. It just hangs. And
> > does not proceed at all. Is this an issue with way my script handles
> > the cluster node. Or is there an method for the hostfile. Thanks.
> >
> > --
> > Sam aka Vijju
> > :)~
> > Linux: Open, True and Cool
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Sam aka Vijju
:)~
Linux: Open, True and Cool