Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] ./configure error on windows while installing openmpi-1.2.4(latest)
From: George Bosilca (bosilca_at_[hidden])
Date: 2007-11-28 13:20:50


If your F77 compiler do not support array of LOGICAL variables (which
seems to be the case if you look in the config.log file), then you're
left with only one option. Remove the F77 support from the
compilation. This means adding the --disable-mpi-f77 option to the ./
configure.

   Thanks,
     george.

On Nov 28, 2007, at 9:24 AM, geetha r wrote:

> Hi,
> Subject: "Need exact command line for ./configure
> {optionslist} " to build OPENMPI-1.2.4 on windows."
>
>
> while configuration script checking the FORTRAN77 compiler , iam
> getting following error,so openmpi- build is unsuccessful on
> windows(with configure script)
>
> checking for correct handling of FORTRAN logical arrays... no
> configure: error: Error determining if arrays of logical values work
> properly.
>
>
> i want to build, openmpi-1.2.4 (which is downloaded from MINGW), on
> windows -2000 machine.
>
> can somebody give proper build command i can use to "build opennmpi
> on windows-2000" machine.
>
> i.e
>
> ./configure .......(options list)
>
> can some body pls tell "exact options to pass" in the option list.
>
> iam using cygwin to build openmpi on windows.
>
> PS:
> I am attaching the output files.
>
> config.log -> actual log file.
> config.out -> output of the ./configure file
> make.out -> fail because, configure build unsuccess on windows.
> make.install-> fail because, configure build unsuccess on windows
>
>
> PS: I am using all g77,g++,gcc from MINGW package.
>
> i have downloaded and added g95 also, but which does not solve my
> problem.
>
> Thanks,
> Geetha
>
> *****************************************************************************
> ** **
> ** WARNING: This email contains an attachment of a very suspicious
> type. **
> ** You are urged NOT to open this attachment unless you are
> absolutely **
> ** sure it is legitimate. Opening this attachment may cause
> irreparable **
> ** damage to your computer and your files. If you have any
> questions **
> ** about the validity of this message, PLEASE SEEK HELP BEFORE
> OPENING IT. **
> ** **
> ** This warning was added by the IU Computer Science Dept. mail
> scanner. **
> *****************************************************************************
>
> <
> make
> .install
> .zip
> >
> <
> make
> .out
> .zip
> >
> <
> config
> .out.zip><config.zip>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users



  • application/pkcs7-signature attachment: smime.p7s