Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] warning:regcache incompatible with malloc
From: de Almeida, Valmor F. (dealmeidav_at_[hidden])
Date: 2007-11-27 16:45:19


Thanks,

--
Valmor
> -----Original Message-----
> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]]
On
> Behalf Of Tim Prins
> Sent: Tuesday, November 27, 2007 10:37 AM
> To: Open MPI Users
> Subject: Re: [OMPI users] warning:regcache incompatible with malloc
> 
> Hi Valmor,
> 
> I prefer to just set the environment variable in my .bashrc so I never
> have to think about it again. Also it might be slightly better since
> Open MPI tries to be network neutral, and linking the application
> against the Myrinet libraries violates that principle. But if you are
> only ever going to use the particular compilation with Myrinet
anyways,
> I suppose it does not matter.
> 
> I guess this is a long way of saying that it is just personal
preference.
> 
> Hope this helps,
> 
> Tim
> 
> 
> de Almeida, Valmor F. wrote:
> > Hello,
> >
> > I am getting the warnings after an upgrade to
> > mx-1.2.4 and openmpi-1.2.4.
> >
> > Either using the env variable setting MX_RCACHE=2, or linking the
> > application with -lmyriexpress removes the warnings.
> >
> > Is either one of them the preferred way of doing it?
> >
> > Thanks,
> >
> > --
> > Valmor
> >
> >> -----Original Message-----
> >> From: users-bounces_at_[hidden]
[mailto:users-bounces_at_[hidden]]
> > On
> >> Behalf Of Scott Atchley
> >> Sent: Tuesday, July 10, 2007 3:31 PM
> >> To: Open MPI Users
> >> Subject: Re: [OMPI users] warning:regcache incompatible with malloc
> >>
> >> On Jul 10, 2007, at 3:24 PM, Tim Prins wrote:
> >>
> >>> On Tuesday 10 July 2007 03:11:45 pm Scott Atchley wrote:
> >>>> On Jul 10, 2007, at 2:58 PM, Scott Atchley wrote:
> >>>>> Tim, starting with the recently released 1.2.1, it is the
default.
> >>>> To clarify, MX_RCACHE=1 is the default.
> >>> It would be good for the default to be something where there is no
> >>> warning
> >>> printed (i.e. 0 or 2). I see the warning on the current trunk.
> >>>
> >>> Tim
> >> After further discussion in-house, the warning can be avoided if -
> >> lmyriexpress is included when linking the app (i.e. if it is in
mpicc
> >> when linking).
> >>
> >> Another clarification, the regache does work with several
replacement
> >> malloc libraries. If the user application overloads mmap(),
munmap()
> >> and sbrk(), then it may or may not work. In this case, the user
> >> should use MX_RCACHE=0.
> >>
> >> Scott
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> 
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users