Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems compiling 1.2.4 using Intel Compiler 10.1.006 on Leopard
From: Mark Dobossy (mdobossy_at_[hidden])
Date: 2007-11-21 15:15:00


Thanks for the suggestion Jeff.

Unfortunately, that didn't fix the issue.

-Mark

On Nov 21, 2007, at 7:55 AM, Jeff Squyres wrote:

> Can you try also adding CCASFLAGS=-no-multibyte-chars?
>
>
> On Nov 20, 2007, at 2:45 PM, Mark Dobossy wrote:
>
>> I am running into some roadblocks in compiling OpenMPI 1.2.4 using
>> the latest Intel Compilers (icc, icpc, ifort) version 10.1.006 on OS
>> X Leopard (10.5.1). Using the last revision of the intel compilers
>> (version 10.0.20) works, but I need the 10.1 compilers to fix
>> compilation of the code I am trying to parallelize, so I need to get
>> everything working with 10.1.x.
>>
>> If I issue my standard ./configure line:
>> ./configure --prefix=/usr/local/openmpi --with-fortran --enable-
>> shared --disable-static --with-xgrid
>>
>> None of the test c or c++ programs can be compiled, due to a locale
>> error:
>> Catastrophic error: could not set locale "" to allow processing of
>> multibyte characters
>>
>> This is a problem that intel seems to know about, and they have
>> suggested adding a -no-multibyte-chars flag to fix it. When I add
>> the -no-multibyte-chars flag (via CFLAGS=-no-multibyte-chars
>> CXXFLAGS=-no-multibyte-chars), the configure script runs
>> successfully. However, when I then try to compile, I fail with the
>> following when making asm:
>>
>> Making all in asm
>> source='asm.c' object='asm.lo' libtool=yes \
>> DEPDIR=.deps depmode=none /bin/sh ../../config/depcomp \
>> /bin/sh ../../libtool --tag=CC --mode=compile /Users/mark/Desktop/
>> openmpi-1.2.4/config/compile icc -DHAVE_CONFIG_H -I. -I../../opal/
>> include -I../../orte/include -I../../ompi/include -I../.. -
>> D_REENTRANT -O3 -DNDEBUG -no-multibyte-chars -finline-functions -
>> fno-strict-aliasing -restrict -c -o asm.lo asm.c
>> libtool: compile: /Users/mark/Desktop/openmpi-1.2.4/config/compile
>> icc -DHAVE_CONFIG_H -I. -I../../opal/include -I../../orte/include -
>> I../../ompi/include -I../.. -D_REENTRANT -O3 -DNDEBUG -no-multibyte-
>> chars -finline-functions -fno-strict-aliasing -restrict -c asm.c -
>> fno-common -DPIC -o .libs/asm.o
>> rm -f atomic-asm.s
>> ln -s "../../opal/asm/generated/atomic-local.s" atomic-asm.s
>> /bin/sh ../../libtool --mode=compile /Users/mark/Desktop/
>> openmpi-1.2.4/config/compile icc -O3 -DNDEBUG -no-multibyte-chars -
>> finline-functions -fno-strict-aliasing -restrict -c -o atomic-asm.lo
>> atomic-asm.s
>> libtool: compile: /Users/mark/Desktop/openmpi-1.2.4/config/compile
>> icc -O3 -DNDEBUG -no-multibyte-chars -finline-functions -fno-strict-
>> aliasing -restrict -c atomic-asm.s -fno-common -DPIC -o .libs/
>> atomic-asm.o
>> /bin/sh ../../libtool --tag=CC --mode=link /Users/mark/Desktop/
>> openmpi-1.2.4/config/compile icc -O3 -DNDEBUG -no-multibyte-chars -
>> finline-functions -fno-strict-aliasing -restrict -export-dynamic
>> -Wl,-u,_munmap -Wl,-multiply_defined,suppress -o libasm.la asm.lo
>> atomic-asm.lo -lutil
>> libtool: link: ar cru .libs/libasm.a .libs/asm.o .libs/atomic-asm.o
>> ar: .libs/atomic-asm.o: No such file or directory
>> make[2]: *** [libasm.la] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all-recursive] Error 1
>>
>>
>> Attached to this email are two tar/gzipped files. The first,
>> "openMPI_config_fail.tgz" contains the config.log, and output from ./
>> configure, if I do not specify the -no-multibyte-chars option. The
>> second, openMPI_make_fail.tgz, contains the config.log, ./configure
>> output, and make output, if I do specify -no-multibyte-chars.
>>
>> Any feedback on how to solve this issue would be greatly
>> appreciated. Thanks!
>>
>> -Mark
>>
>>
>> <openMPI_config_fail.tgz><openMPI_make_fail.tgz><mime-
>> attachment.txt><mime-attachment.txt>
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users