Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI - compilation
From: Brock Palen (brockp_at_[hidden])
Date: 2007-11-14 13:18:06


Dont use the name 'test' test is a unix command and it causes
problems when you name things 'test'

If you try
mpirun -np 4 ./test

it will work because that will use the test you just created not the
regular 'test'
But really dont use the name test and it will work as expected.

Brock Palen
Center for Advanced Computing
brockp_at_[hidden]
(734)936-1985

On Nov 14, 2007, at 10:07 AM, Sajjad wrote:

> Hello,
>
> I have installed openmpi from the ubuntu repository for the 64-bit
> dual core AMD processor.
>
> and i tried to compile the simple test program with the help of the
> tutorial page but nothing seems to happen.
>
> #include <stdio.h>
> #include <mpi.h>
>
> int main(int argc,char *argv[])
> {
> int rank;
>
> MPI_Init(&argc,&argv);
> MPI_Comm_rank(MPI_COMM_WORLD, &rank);
> printf("my rank=%d\n",rank);
> MPI_Finalize();
>
> return 0;
> }
>
>
> then from the console i issued the following command
>
> mpicc test.c -o test
> mpirun -np 4 test
>
> nothing happens. actually after the command "mpicc test.c -o test"
> shouldnt i be having a .o file?
>
> I do not understand how do i get to know if my current installation is
> fine or not.
>
>
> Any suggestion?
>
>
>
> Regards
> Sajjad
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>