Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] fail to link when looking in other directories containing other MPI libraries
From: Harald Servat (harald_at_[hidden])
Date: 2007-11-08 11:52:20


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello to all,

  I'm working on SGI Altix machine (IA64) which provides its own MPI
library. It is installed under /usr.

  I've installed OpenMPI 1.2 on my own user area in order to do some tests.
  However, when I link the test application with the mpicc from OpenMPI
and the command line contains -L /usr/lib mpicc fails telling me that
it's unable to find some symbols from the OpenMPI lib (I suppose that it
tries to use /usr/lib/libmpi.* instead of $OMPI_HOME/lib/libmpi.*).

  Shouldn't mpicc force the usage of $OMPI_HOME/lib/libmpi* at the link
stage and avoid other MPI libraries?

Thank you!,

**

harald_at_bscsmp01:~>
/home/Computacional/harald/aplic/openmpi/1.2/bin/mpicc prova-mpi.c
harald_at_bscsmp01:~>
/home/Computacional/harald/aplic/openmpi/1.2/bin/mpicc prova-mpi.c
- -L/usr/lib
/tmp/ccIsf1pD.o: In function `main':
prova-mpi.c:(.text+0x61): undefined reference to `ompi_mpi_comm_world'
prova-mpi.c:(.text+0x70): undefined reference to `ompi_mpi_comm_world'
collect2: ld returned 1 exit status

and prova-mpi.c is like this

#include <mpi.h>

int main (int argc, char *argv[])
{
        int r;

        r = MPI_Init (&argc, &argv);
        r = MPI_Barrier (MPI_COMM_WORLD);
        r = MPI_Finalize();
}

Regards,

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (FreeBSD)

iD8DBQFHMz7EwMPeuqUCg9wRAlAjAJwIskAbJgu1q2smj7T6b/CHWJOf4ACeLcFW
1Qrf82rG54jvyeBjJ/RrI6I=
=Guy4
-----END PGP SIGNATURE-----