Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Francesco Pietra (chiendarret_at_[hidden])
Date: 2007-11-07 08:05:06


I wonder whether any suggestion can be offered about segmentation fault
occurring on running a docking program (DOCK 6.1, written in C) on Debian Linux
amd64 etch, i.e. dual opterons machine. Running DOCK6.1 parallel was OK until
yesterday. I vaguely remember that before these problems I carried out a

apt-get upgrade

and something was done for OpenMPI.

DOCK 6.1 was compiled:

./configure gnu parallel
MPICH_HOME=/usr/local
export MPICH_HOME
make dock

by pointing MPICH (for which DOCK 6.1 is configured, to my installation of
OpenMPI 1.2.3

In my .bashrc:

DOCK_HOME=/usr/local/dock6
PATH=$PATH:$DOCK_HOME/bib; export DOCK_HOME PATH

MPI_HOME=/usr/local
export MPI_home

which mpicxx
/usr/local/bin/mpicxx

updatedb
locate mpi.h
/usr/include/sc/util/group/memmtmpi.h
/usr/include/sc/util/group/messmpi.h
/usr/dock6/src/dock/base_mpi.h
/usr/local/include/mpi.h
/usr/local/openmpi-1.2.3/ompi/include/mpi.h
/usr/local/openmpi-1.2.3/ompi/include/mpi.h.in
/usr/local/openmpi-1.2.3/ompi/mpi/f77/prototypes_mpi.h
-------

On these basis, running:

mpirun -np 4 dock6.mpi -i dock.in -o dock.out

the process halted with error message:

Initialing MPI routines ....
[deb64:03540] *** Process received signal ***
[deb64:03540] Signal: Segmentation fault (11)
[deb64:03540] Signal code: Address not mapped (1)
[deb64:03540] Failing at address: 0x2b9ef5691000
dock6.mpi[3540]: segfault at 00002b9ef56910000 rip 0000000000447b1b rsp
00007fff43c137b0 error 6
[deb64:03540] [0] /lib/libthread.so.0 [0x2b9e681bc410]
[deb64:03540] [1] dock6.mpi (_ZN60rient12match_ligandER7DOCKMol+0x40b)
[0x447b1b]
[deb64:03540] [2] dock6.mpi (main+0xaf5) [0x42cc75]
[deb64:03540] [3] dock6.mpi /lib/libc.so.6(__libc_start_main+0xda)
[0x2b9e682e14ca]
[deb64:03540] [4] dock6.mpi (__gxx_personality_v0+0xc2) [0x41b4ea]
[deb64:03540] *** End of error message ***
mpirun noticed that jpb rank 0 with PID 3537 on node deb64 exited on signal 15
(Terminated).
3 additional processes aborted (not shown)

Thanks
francesco pietra

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com