Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Karsten Bolding (karsten_at_[hidden])
Date: 2007-11-07 04:45:24


Hello

As it seems I need a feature only present in the svn-version of OpenMPI
I'm in the process of installing and compiling this version.

I've tried on two different machines.

1) debian everything worked OK.
autoconf 2.61-4
automake 1:1.10+nogfdl-1
libtool 1.5.24-1
ifort Version 10.0

2) ubuntu (single processor/quad-core)
autoconf 2.61-4
automake 1:1.10+nogfdl-1
libtool 1.5.24-1ubuntu1
ifort Version 10.0

make[2]: Entering directory
`/data/kb/compile/openmpi-svn/orte/tools/orteboot'
/bin/sh ../../../libtool --tag=CC --mode=link gcc -g -Wall -Wundef
-Wno-long-long -Wsign-compare -Wmissing-prototypes -Wstrict-prototypes
-Wcomment -pedantic -Werror-implicit-function-declaration
-finline-functions -fno-strict-aliasing -pthread -export-dynamic -o
orteboot orteboot.o ../../../orte/libopen-rte.la -lnsl -lutil -lm
gcc -g -Wall -Wundef -Wno-long-long -Wsign-compare -Wmissing-prototypes
-Wstrict-prototypes -Wcomment -pedantic
-Werror-implicit-function-declaration -finline-functions
-fno-strict-aliasing -pthread -o .libs/orteboot orteboot.o
-Wl,--export-dynamic ../../../orte/.libs/libopen-rte.so -lnsl -lutil
-lm -Wl,--rpath -Wl,/opt/openmpi-svn/lib
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_sys_limits'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_cr_finalize'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_cr_set_enabled'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_path_access'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_crs_base_extract_expected_component'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_crs_base_state_str'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_mutex_check_locks'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_progress_set_yield_when_idle'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_cr_init'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_progress_set_event_flag'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_crs_base_snapshot_t_class'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_cr_reg_coord_callback'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_cr_output'
../../../orte/.libs/libopen-rte.so: undefined reference to
`opal_get_num_processors'
collect2: ld returned 1 exit status
make[2]: *** [orteboot] Error 1

If I do:
strings orte/.libs/libopen-rte.so.0.0.0 | grep opal_get_num_processors
I get:
opal_get_num_processors

Are there any known issues with ubuntus version of libtool. When I run
./autogen.sh
I get this:

[Running] autoheader
** Adjusting libtool for OMPI :-(
   ++ patching for pathscale multi-line output (LT 1.5.x)
[Running] autoconf
[Running] libtoolize --automake --copy --ltdl
   -- Moving libltdl to opal/
** Adjusting libltdl for OMPI :-(
   ++ patching for argz bugfix in libtool 1.5
      -- your libtool doesn't need this! yay!
   ++ patching 64-bit OS X bug in ltmain.sh
      -- your libtool doesn't need this! yay!
   ++ RTLD_GLOBAL in libltdl
      -- your libltdl doesn't need this! yay!

I don't get that on machine 1.

I tried to copy orte/.libs/libopen-rte.so from 1 to 2 without luck.

kb

-- 
----------------------------------------------------------------------
Karsten Bolding                    Bolding & Burchard Hydrodynamics
Strandgyden 25                     Phone: +45 64422058
DK-5466 Asperup                    Fax:   +45 64422068
Denmark                            Email: karsten_at_[hidden]
http://www.findvej.dk/Strandgyden25,5466,11,3
----------------------------------------------------------------------