Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-10-24 20:52:01


By default, I believe that orte assumes that the orted is in the same
location on all nodes. If it's not, you should be able to use the
following:

1. Make a sym link such that /usr/local/bin/orted appears on all of
your nodes. You implied that you tried this, but I find it hard to
believe that that didn't work -- the error message you show clearly
indicates that it's looking for /usr/local/bin/orted. If it's there
(and executable), it should work.

2. I assume you're using the rsh/ssh launcher. If this is the case,
use the mca_pls_rsh_orted MCA parameter to /usr/bin/orted. E.g.:

     mpirun --mca pls_rsh_orted /usr/bin/orted ...

On Oct 1, 2007, at 8:26 AM, Amit Kumar Saha wrote:

> hello,
>
> I am using Open MPI 1.2.3 to run a task on 4 hosts as follows:
>
> amit_at_ubuntu-desktop-1:~/mpi-exec$ mpirun --np 4 --hostfile
> mpi-host-file ParallelSearch
> bash: /usr/local/bin/orted: No such file or directory
>
> The problem is that 'orted' is not found on one of the 4 hosts. I
> investigated the problem and found out that whereas 'orted' is stored
> in /usr/local/bin on all the other 3 hosts, it is in /usr/bin/orted on
> the erroneous host. I tried to create a soft link to solve the problem
> but sadly it is not so simple, it seems.
>
> It would be nice to know how to get around this problem.
>
> Thanks,
> Amit
> --
> Amit Kumar Saha
> *NetBeans Community Docs Coordinator*
> me blogs@ http://amitksaha.blogspot.com
> URL:http://amitsaha.in.googlepages.com
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems