Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-10-06 12:32:19


I am certainly no mac expert, but this is pretty weird to me. I
build on my MacBook Pro all the time (10.4.10 and same version of
Xtools).

In fact, I just downloaded and built 1.2.3 and built it -- here's a
snipit from the configure output:

-----
checking for OMPI FCFLAGS...
checking for OMPI LDFLAGS... -Wl,-u,_munmap -Wl,-
multiply_defined,suppress
checking for OMPI LIBS...
checking for OMPI extra include dirs...

*** Final output
configure: creating ./config.status
config.status: creating ompi/include/ompi/version.h
config.status: creating orte/include/orte/version.h
config.status: creating opal/include/opal/version.h
config.status: creating opal/mca/backtrace/Makefile
....etc.
-----

So you can see that it works for me. :-(

It looks like your system is tripping up on sed somehow -- do you
have an alternate version of sed installed, perhaps? Here's what I
have:

% where sed
/usr/bin/sed
% gmd5sum /usr/bin/sed
35af2dffa7ff32b54e1840c0e432382d /usr/bin/sed
% gsha1sum /usr/bin/sed
0b37a699bfb458ec29c10d8d9c5df278ee3d9e8b /usr/bin/sed

On Sep 25, 2007, at 9:46 AM, Michael Clover wrote:

> I have been attempting to compile open-mpi, both 1.2.2 and 1.2.3 on
> a new iMac (core 2 duo, 2.4 GHz, OS X 10.4.10), using gfortran as
> my fortran compiler, and a very recent Xtools (ld -v gives version
> cctools-622.5.obj~13). I have tried both the full line,
> configure --prefix=/usr/local/openmpi --disable-mpi-cxx --disable-
> mpi-f90 --without-xgrid FC=gfortran
> as well as a truncated line,
> configure --prefix=/usr/local/openmpi
> and switched compilers via
> setenv FC g95
> configure --prefix=/usr/local/openmpi --disable-mpi-cxx --disable-
> mpi-f90 --without-xgrid
>
> and in all cases, after minutes of working away, get to the point
> that someone else got to last year (when it tries to create the
> Makefiles, etc) and get the following output (approximately 200
> pairs of sed:33 and sed:4's). This has been happening for over a
> week, with reboots every night. I attach the configure terminal
> output as well as the log file (for a 1.2.2 attempt).
> <ompi-output.tar.gz>
>
> ...checking for OMPI LIBS... -lSystemStubs
> checking for OMPI extra include dirs... openmpi
>
> *** Final output
> configure: creating ./config.status
> config.status: creating ompi/include/ompi/version.h
> sed: 33: ./confstatkVPvQm/subs-3.sed: unescaped newline inside
> substitute pattern
> sed: 4: ./confstatkVPvQm/subs-4.sed: unescaped newline inside
> substitute pattern
> config.status: creating orte/include/orte/version.h
> sed: 33: ./confstatkVPvQm/subs-3.sed: unescaped newline inside
> substitute pattern
>
>
>
> Michael Clover
> mclover_at_[hidden]
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems