Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Michael Clover (mclover_at_[hidden])
Date: 2007-09-25 03:46:03


I have been attempting to compile open-mpi, both 1.2.2 and 1.2.3 on a
new iMac (core 2 duo, 2.4 GHz, OS X 10.4.10), using gfortran as my
fortran compiler, and a very recent Xtools (ld -v gives version
cctools-622.5.obj~13). I have tried both the full line,
configure --prefix=/usr/local/openmpi --disable-mpi-cxx --disable-mpi-
f90 --without-xgrid FC=gfortran
as well as a truncated line,
configure --prefix=/usr/local/openmpi
and switched compilers via
setenv FC g95
configure --prefix=/usr/local/openmpi --disable-mpi-cxx --disable-mpi-
f90 --without-xgrid

and in all cases, after minutes of working away, get to the point
that someone else got to last year (when it tries to create the
Makefiles, etc) and get the following output (approximately 200 pairs
of sed:33 and sed:4's). This has been happening for over a week,
with reboots every night. I attach the configure terminal output as
well as the log file (for a 1.2.2 attempt).
  

...checking for OMPI LIBS... -lSystemStubs
checking for OMPI extra include dirs... openmpi

*** Final output
configure: creating ./config.status
config.status: creating ompi/include/ompi/version.h
sed: 33: ./confstatkVPvQm/subs-3.sed: unescaped newline inside
substitute pattern
sed: 4: ./confstatkVPvQm/subs-4.sed: unescaped newline inside
substitute pattern
config.status: creating orte/include/orte/version.h
sed: 33: ./confstatkVPvQm/subs-3.sed: unescaped newline inside
substitute pattern

Michael Clover
mclover_at_[hidden]