Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: George Bosilca (bosilca_at_[hidden])
Date: 2007-09-21 09:51:41


As Jeff indicate setting btl to ^openib will only remove warnings
about openib. You might want to suppress th warnings from udapl as
well. Therefore btl=^openib,udapl (which remove support for both
openib and udapl) is what you're looking for.

   george.

On Sep 20, 2007, at 8:40 PM, Jeff Squyres wrote:

> Open MPI currently has a "negative ACK" kind of assumption built into
> it -- it assumes that if you have high-speed network support built
> into it, you'll want to know if you're not using it.
>
> You're correct that you can disable this warning by setting the "btl"
> MCA parameter to ^openib (or any other inclusive value that does not
> have "openib" in it).
>
>
> On Sep 19, 2007, at 1:19 PM, Tobias Burnus wrote:
>
>> If I start an MPI job with:
>>
>> mpirun -np 2
>>
>> the following gets shown:
>>
>> ---------------------------------------------------------------------
>> -
>> ----
>> [0,1,0]: OpenIB on host tux was unable to find any HCAs.
>> Another transport will be used instead, although this may result in
>> lower performance.
>> ---------------------------------------------------------------------
>> -
>> ----
>> ---------------------------------------------------------------------
>> -
>> ----
>> [0,1,0]: uDAPL on host tux was unable to find any NICs.
>> Another transport will be used instead, although this may result in
>> lower performance.
>> ---------------------------------------------------------------------
>> -
>> ----
>> libibverbs: Fatal: couldn't read uverbs ABI version.
>>
>>
>> before it runs the job. The point is: As I have *one* SMP machine,
>> there
>> is no need to use Infiniband etc. as accessing the local memory
>> directly
>> will be faster ;-)
>>
>> Why is this message shown in this case?
>>
>> (I read that one can suppress the first message via "btl=^openib" in
>> /etc/openmpi-mca-params.conf:.)
>>
>> Tobias
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users



  • application/pkcs7-signature attachment: smime.p7s