Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-08-15 11:54:19


For the web archives: moving this conversation to a higher-bandwidth
medium... (telephone) :-)

On Aug 15, 2007, at 11:52 AM, Andrew Friedley wrote:

> Point away :) Dunno if it's something I'll be able to do on my
> own, but
> I'll give it a shot.
>
> Andrew
>
> Jeff Squyres wrote:
>> You are hitting this bug:
>>
>> https://svn.open-mpi.org/trac/ompi/ticket/1047
>>
>> I have unfortunately not had time to dig into it :-(, but I'd be
>> happy to point you in the right direction...
>>
>>
>> On Aug 15, 2007, at 11:44 AM, Andrew Friedley wrote:
>>
>>> I'm helping someone at LLNL get running with Open MPI, and the
>>> current
>>> snag seems to be that stdin redirection doesnt work right. A quick
>>> look
>>> at the orterun manpage indicates something like this should work:
>>>
>>> mpirun -np 1 cat < foo.txt
>>>
>>> If I run just say on the head node without any slurm allocation,
>>> this
>>> works just the same as `cat < foo.txt`. But if I grab a one node
>>> interactive slurm allocation, then run the same command again (cat
>>> should now be running out on the compute node), I get no output. Is
>>> this expected behavior? I'm seeing this on a recent trunk build and
>>> 1.2.3 release.
>>>
>>> Andrew
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems