Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Michael Komm (michael.komm_at_[hidden])
Date: 2007-08-07 13:35:19


Thanks Christian it works just fine now!
I altered LIBRARY_PATH and LD_PATH but not this one :)
                                    Michael

______________________________________________________________
> Od: christian.becker_at_[hidden]
> Komu: Open MPI Users <users_at_[hidden]>
> Datum: 07.08.2007 19:32
> Pøedmìt: Re: [OMPI users] OpenMPI and PathScale problem
>
>Hi Michael,
>
>you have to add the path to the openmpi libraries to the LD_LIBRARY_PATH
variable
>
>export LD_LIBRARY_PATH=/home/fort/usr//lib
>
>should fix the problem.
>
>Bye,
>Christian
>
>Michael Komm wrote:
>> I'm trying to make work the pathscale fortran compiler with OpenMPI on
a 64bit Linux machine and can't get passed a simple demo program. Here is
detailed info:
>>
>> pathf90 -v
>> PathScale EKOPath(TM) Compiler Suite: Version 2.5
>> Built on: 2006-08-22 21:02:51 -0700
>> Thread model: posix
>> GNU gcc version 3.3.1 (PathScale 2.5 driver)
>>
>> mpif90 --show
>> pathf90 -I/home/fort/usr//include -pthread -I/home/fort/usr//lib
-L/home/fort/usr//lib -lmpi_f90 -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl
-Wl,--export-dynamic -lnsl -lutil -lm -ldl
>>
>> The OpenMPI version 1.2.3 resides in the /home/fort/usr/ directory.
>>
>> When I compile a simple program using
>>
>> mpif90 -o test test.f90
>>
>> I get a binary all right but it has broken linked libraries
>>
>> ldd test
>> libmpi_f90.so.0 => not found
>> libmpi_f77.so.0 => not found
>> libmpi.so.0 => /usr/lib64/lam/libmpi.so.0 (0x0000003db3600000)
>> libopen-rte.so.0 => not found
>> libopen-pal.so.0 => not found
>> libdl.so.2 => /lib64/libdl.so.2 (0x0000003db3200000)
>> libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003db9900000)
>> libutil.so.1 => /lib64/libutil.so.1 (0x0000003db8400000)
>> libmv.so.1 => /opt/pathscale/lib/2.5/libmv.so.1
(0x0000002a9557f000)
>> libmpath.so.1 => /opt/pathscale/lib/2.5/libmpath.so.1
(0x0000002a956a8000)
>> libm.so.6 => /lib64/tls/libm.so.6 (0x0000003db3000000)
>> libpathfortran.so.1 =>
/opt/pathscale/lib/2.5/libpathfortran.so.1 (0x0000002a957c9000)
>> libpthread.so.0 => /lib64/tls/libpthread.so.0
(0x0000003db3800000)
>> libc.so.6 => /lib64/tls/libc.so.6 (0x0000003db2d00000)
>> /lib64/ld-linux-x86-64.so.2 (0x0000003db2900000)
>>
>> The demo program fails to start due to missing shared libraries. In
addition the pathf90 uses some lame mpi library instead of openMPI! Any
ideas on where the problem could be?
>>
>> Michael
>>
>> ********************************************************************
>> Mgr. Michael Komm
>> Tokamak Department
>> Institute of Plasma Physics of Academy of Sciences of Czech Republic
>> E-mail:komm_at_[hidden]
>> Za Slovankou 3
>> 182 00
>> PRAGUE 8
>> ********************************************************************
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>_______________________________________________
>users mailing list
>users_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/users
>