Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Graham Jenkins (Graham.Jenkins_at_[hidden])
Date: 2007-08-06 17:02:36


This iteme was originally sent to the NAMD mailing list, but it occurred
to me that it's something you guys may ahve seen in another vein .. and
may have a solution for ..

I'm trying to build charm++ on a SL5 x86_64 machine on which the
openmpi-1.1.1-5.el5.x86_64 RPM has been installed.

So here's the sequence:

--
cd charm-5.9
module load openmpi-intel
./build charm++ mpi-linux-amd64 --libdir=/usr/lib64/openmpi \
                                --incdir=/usr/include/openmpi
 ..
cd tests/charm++/simplearrayhello
 make
../../../bin/charmc  -language charm++ -o hello hello.o
/usr/bin/ld: cannot find -lmpich
collect2: ld returned 1 exit status
--
Bottom line .. charm++ doesn't know about libmpi, even though it exists
thus:
  ls -1 /opt/sw/openmpi-1.2.3-i/lib/libmpi.??
    /opt/sw/openmpi-1.2.3-i/lib/libmpi.la
    /opt/sw/openmpi-1.2.3-i/lib/libmpi.so
So .. anybody got a solution .. please?
-- 
Graham Jenkins
Senior Software Specialist, E-Research
Email: Graham.Jenkins_at_[hidden]
Tel:   +613 9905-5942
Mob:   +614 4850-2491