Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Luke Hur (sgh36_at_[hidden])
Date: 2007-08-05 16:41:58


Hi there!

I have just installed torque and openmpi and trying to make them work.
I ran ./configure --with-tm=/usr/local for openmpi and torque integration.
But when I run "mpirun -H node2 hello" on "node1", it asks the password of
node2.
And when I typed the password, eventually it tells below error message.

mpirun: forcibly killing job...
[node1:19854] ERROR: A daemon on node blade2--escience failed to start as
expected.
[node1:19854] ERROR: There may be more information available from
[node1:19854] ERROR: the remote shell (see above).
[node1:19854] The daemon received a signal 2.

What is the problem?
Please help!
Luke

On 02/08/07, Jeff Squyres <jsquyres_at_[hidden]> wrote:
>
> On Aug 1, 2007, at 11:38 AM, S.Sundar Raman wrote:
>
> > dear openmpi users,
> > i m trying to compile openmpi with pgf90 compiler in AMD opteron
> > system.
> > i followed the procedure given in the mailer archives.
>
> What procedure are you referring to, specifically?
>
> > i found the following problem.
> > please kindly help me in this regard and i m eagerly waiting for
> > your reply
> > make[2]: Entering directory `/usr/local/openmpi-1.2.3/ompi/mpi/f90'
> >
> > /bin/sh ../../../libtool --mode=link pgf90 -I../../../ompi/include -
> > I../../../ompi/include -I. -I. -I../../../ompi/mpi/f90 -export-
> > dynamic -o libmpi_f90.la -rpath /usr/local/mpi/lib mpi.lo
> > mpi_sizeof.lo mpi_comm_spawn_multiple_f90.lo mpi_testall_f90.lo
> > mpi_testsome_f90.lo mpi_waitall_f90.lo mpi_waitsome_f90.lo
> > mpi_wtick_f90.lo mpi_wtime_f90.lo -lnsl -lutil -lm
> >
> > libtool: link: pgf90 -shared -fPIC -Mnomain .libs/mpi.o .libs/
> > mpi_sizeof.o .libs/mpi_comm_spawn_multiple_f90.o .libs/
> > mpi_testall_f90.o .libs/mpi_testsome_f90.o .libs/
> > mpi_waitall_f90.o .libs/mpi_waitsome_f90.o .libs/
> > mpi_wtick_f90.o .libs/mpi_wtime_f90.o -lnsl -lutil -lm -Wl,-soname -
> > Wl,libmpi_f90.so.0 -o .libs/libmpi_f90.so.0.0.0
> >
> > /usr/bin/ld: .libs/mpi.o: relocation R_X86_64_PC32 against
> > `__pgio_ini' can not be used when making a shared object; recompile
> > with -fPIC
>
> I can usually compile with the PGI compilers without needing to do
> anything special (PGI v6.2-5 and 7.0-2), although I usually do add
> the following option to configure:
>
> --with-wrapper-cxxflags=-fPIC
>
> This puts "-fPIC" in the flags that the mpiCC wrapper compiler will
> automatically insert when compiling MPI C++ applications.
>
> Can you send all the information listed here:
>
> http://www.open-mpi.org/community/help/
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>