Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-07-13 14:23:20


Ah -- intel 10. I think you said this before but I blew right past
it. I have not personally tested with intel 10; I don't know if
anyone else on the team has.

My support guy here at Cisco tells me that he's got a license for it
and has been looking for an excuse to spend some time to install
them. Hopefully I'll have access within the next several [business]
days; I can check it out then. Perhaps we're tripping a problem with
that specific version of the compiler (wouldn't be the first time ;-) ).

On Jul 13, 2007, at 6:16 AM, Ricardo Reis wrote:

> On Thu, 12 Jul 2007, Jeff Squyres wrote:
>
>> I admit to being baffled. :-(
>
> My systems seem to have that effect on people... :)
>
>> If general C++ applications seem to be working with icc/icpc, I do
>> not know why OMPI would fail for you with icc/icpc (especially while
>> accessing stack memory). What version of icc/icpc are you using?
>> There were some bugs in the 8.x series that caused problems, IIRC...
>
> 5001.0 $ icc --version
> icc (ICC) 10.0 20070426
> Copyright (C) 1985-2007 Intel Corporation. All rights reserved.
>
> 5002.0 $ ifort --version
> ifort (IFORT) 10.0 20070426
> Copyright (C) 1985-2007 Intel Corporation. All rights reserved.
>
>> Do the intel compilers come with any error checking tools to give
>> more diagnostics?
>
> yes, they come with their own debugger. I'll try to use it and send
> more info when done.
>
> thanks!,
>
> Ricardo Reis
>
> 'Non Serviam'
>
> PhD student @ Lasef
> Computational Fluid Dynamics, High Performance Computing, Turbulence
> <http://www.lasef.ist.utl.pt>
>
> &
>
> Cultural Instigator @ Rádio Zero
> http://
> radio.ist.utl.pt_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems