Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Tim Cornwell (tim.cornwell_at_[hidden])
Date: 2007-07-11 05:32:45


I have a problem running openmpi under OS 10.4.10. My program runs
fine under debian x86_64 on an opteron but under OS X on a number of
Mac Book and Mac Book Pros, I get the following immediately on
startup. This smells like a common problem but I could find anything
relevant anywhere. Can anyone provide a hint or better yet a solution?

Thanks,

Tim

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x0000000c
0x04510412 in free ()
(gdb) where
#0 0x04510412 in free ()
#1 0x05d24f80 in opal_install_dirs_expand (input=0x5d2a6b0 "$
{prefix}") at base/installdirs_base_expand.c:67
#2 0x05d24584 in opal_installdirs_base_open () at base/
installdirs_base_components.c:94
#3 0x05d01a40 in opal_init_util () at runtime/opal_init.c:150
#4 0x05d01b24 in opal_init () at runtime/opal_init.c:200
#5 0x051fa5cd in ompi_mpi_init (argc=1, argv=0xbfffde74,
requested=0, provided=0xbfffd930) at runtime/ompi_mpi_init.c:219
#6 0x0523a8db in MPI_Init (argc=0xbfffd980, argv=0xbfffde14) at
init.c:71
#7 0x0005a03d in conrad::cp::MPIConnection::initMPI (argc=1,
argv=@0xbfffde14) at mwcommon/MPIConnection.cc:83
#8 0x00004163 in main (argc=1, argv=0xbfffde74) at apps/cimager.cc:155

------------------------------------------------------------------------
--------
Tim Cornwell, Australia Telescope National Facility, CSIRO
Location: Cnr Pembroke & Vimiera Rds, Marsfield, NSW, 2122, AUSTRALIA
Post: PO Box 76, Epping, NSW 1710, AUSTRALIA
Phone: +61 2 9372 4261 Fax: +61 2 9372 4450 or 4310
Mobile: +61 4 3366 5399
Email: Tim.Cornwell_at_[hidden]
URL: http://www.atnf.csiro.au/people/tim.cornwell
------------------------------------------------------------------------
---------