Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-07-09 09:57:06


You didn't say, but I assume that my other two statements were
therefore correct (1.1.2 works with a static F90 library, 1.2.3 does
not work).

Do you need the MPI F90 bindings? If not, does --disable-mpi-f90
work for you?

On Jul 5, 2007, at 1:37 PM, Yip, Elizabeth L wrote:

>
> 1.2.1 does NOT work for me.
>
> -----Original Message-----
> From: Jeff Squyres [mailto:jsquyres_at_[hidden]]
> Sent: Thu 7/5/2007 2:39 AM
> To: Open MPI Users
> Subject: Re: [OMPI users] Absoft compilation problem
>
> On Jul 2, 2007, at 7:31 PM, Yip, Elizabeth L wrote:
>
> > I downloaded openmpi-1.2.3rc2r15098 from your "nightly snapshot",
> > same problem.
> > I notice in version 1.1.2, you generate libmpi_f90.a instead of
> > the .so files.
>
> Brian clarified for me off-list that we use the same LT for nightly
> trunk and OMPI 1.2.x tarballs.
>
> In 1.1.2, you're correct that we only made static F90 libraries.
>
> Can you clarify/confirm:
>
> - 1.1.2 works for you (static F90 library)
> - 1.2.1 works for you
> - 1.2.3 does not work for you
>
> If this is correct, then something is really, really weird.
>
>
> >
> > -----Original Message-----
> > From: Jeff Squyres [mailto:jsquyres_at_[hidden]]
> > Sent: Sun 7/1/2007 4:03 AM
> > To: Open MPI Users
> > Subject: Re: [OMPI users] Absoft compilation problem
> >
> > I unfortunately do not have access to an Absoft compiler to test
> this
> > with; it looks like GNU Libtool is getting the wrong arguments to
> > pass to the f95 compiler to build a shared library.
> >
> > A quick workaround for this issue would be to disable the MPI F90
> > bindings with the --disable-mpi-f90 switch to configure.
> >
> > Could you try the Open MPI nightly trunk tarball and see if it works
> > there? We use a different version of Libtool to make those
> tarballs.
> >
> >
> > On Jun 30, 2007, at 2:09 AM, Yip, Elizabeth L wrote:
> >
> > >
> > > The attachment shows my problems when I tried to compile openmpi
> > > 1.2.3 with absoft 95
> > > (Absoft 64-bit Fortran 95 9.0 with Service Pack 1). I have
> similar
> > > problems with version 1.2.1, but
> > > no problem with version 1.2.1.
> > >
> > > Elizabeth Yip
> > > <ompi_absoft.tar.gz>
> > > <mime-attachment.txt>
> >
> >
> > --
> > Jeff Squyres
> > Cisco Systems
> >
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> > <ATT5249792.txt>
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> <ATT15994267.txt>

-- 
Jeff Squyres
Cisco Systems