Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Adams, Samuel D Contr AFRL/HEDR (Samuel.Adams_at_[hidden])
Date: 2007-06-27 18:34:18


I have something wrong with having my LD_LIBRARY_PATH variable path set
when I am doing a non-interactive login to remote nodes. These nodes
are running RHEL5.

It looks like something like this:
--------------------------------------------------------------------
[sam_at_prodnode1 fdtd_0.3]$ time mpiexec --host prodnode3 -np 16 fdtd -t
./test_files/tissue.txt -r ./test_files/sphere_x0120y0120z0120.raw -v
Beowulf Computer Cluster (BCC)
AFRL/HED
...
Setting up [gcc production] cluster environment
fdtd: error while loading shared libraries: libmpi.so.0: cannot open
shared object file: No such file or directory
...

For some reason the LD_LIBRARY_PATH is not being set, but the PATH is:
----------------------------------------------------------------------
[sam_at_prodnode1 ~]$ ssh prodnode3 export
Beowulf Computer Cluster (BCC)
AFRL/HED
...
Setting up [gcc production] cluster environment
declare -x G_BROKEN_FILENAMES="1"
declare -x HOME="/home/sam"
declare -x LANG="en_US.UTF-8"
declare -x LESSOPEN="|/usr/bin/lesspipe.sh %s"
declare -x LOGNAME="sam"
declare -x LS_COLORS=""
declare -x MAIL="/var/mail/sam"
declare -x OLDPWD
declare -x
PATH="/usr/local/profiles/gcc-openmpi/bin/:/usr/kerberos/bin:/usr/local/
bin:/bin:/usr/bin:/opt/jdk1.5.0_07/bin"
declare -x PWD="/home/sam"
declare -x SHELL="/bin/bash"
declare -x SHLVL="1"
declare -x SSH_CLIENT="140.140.207.111 51258 22"
declare -x SSH_CONNECTION="140.140.207.111 51258 140.140.207.113 22"
declare -x USER="sam"
[sam_at_prodnode1 ~]$

I have the following in both my .bashrc and .profile in $HOME:
--------------------------------------------------------------------
if [ `hostname | grep "prod"` ]; then
        echo "Setting up [gcc production] cluster environment"
        PATH=/usr/local/profiles/gcc-openmpi/bin/:$PATH
 
LD_LIBRARY_PATH=/usr/local/profiles/gcc-openmpi/lib/:$LD_LIBRARY_PATH
        MANPATH=/usr/local/profiles/gcc-openmpi/man:$MANPATH
fi

Things will work if I use:
$ mpirun --prefix /usr/local/profiles/gcc-openmpi ...

Sam Adams
General Dynamics Information Technology
Phone: 210.536.5945