Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Andrew Friedley (afriedle_at_[hidden])
Date: 2007-06-20 11:41:56


I'm not seeing anything particularly relevant in the libtool
documentation. I think this might be referring to hardcoding paths in
shared libraries?

Using pathf90 for both FC and F77 does not change anything. Should have
been more clear in my first email -- gcc 3.4.5 using pathf90 for FC
works fine.

Even more interesting -- I just tried configuring with --disable-mpi-f77
--disable-mpi-f90 and still see the exact same error. So I'm pretty
convinced this is not a fortran issue. I've tried disabling debugging
and using -O0 as well, but still get the same error.

Is there anywhere else I should be looking? I have to admit, I'm
stumped here..

Andrew

Jeff Squyres wrote:
> It could be; I didn't mention it because this is building ompi_info,
> a C++ application that should have no fortran issues with it.
>
> But then again, who knows? Maybe you're right :-) -- perhaps libtool
> is just getting confused because you used g77 and pathf90 -- why not
> use pathf90 for both FC and F77? pathf90 is capable of compiling
> both Fortran 77 and 90 applications.
>
>
> On Jun 20, 2007, at 5:58 AM, Terry Frankcombe wrote:
>
>> Isn't this another case of trying to use two different Fortran
>> compilers
>> at the same time?
>>
>>
>> On Tue, 2007-06-19 at 20:04 -0400, Jeff Squyres wrote:
>>> I have not seen this before -- did you look in the libtool
>>> documentation? ("See the libtool documentation for more
>>> information.")
>>>
>>> On Jun 19, 2007, at 6:46 PM, Andrew Friedley wrote:
>>>
>>>> I'm trying to build Open MPI v1.2.2 with gcc/g++/g77 3.4.4 and
>>>> pathf90 v2.4 on a linux system, and see this error when compiling
>>>> ompi_info:
>>>>
>>>> /bin/sh ../../../libtool --tag=CXX --mode=link g++ -g -O2 -finline-
>>>> functions -pthread -export-dynamic -o ompi_info components.o
>>>> ompi_info.o output.o param.o version.o ../../../ompi/libmpi.la -
>>>> lnsl -lutil -lm
>>>> libtool: link: unsupported hardcode properties
>>>> libtool: link: See the libtool documentation for more information.
>>>> libtool: link: Fatal configuration error.
>>>> make[2]: *** [ompi_info] Error 1
>>>> make[2]: Leaving directory `/g/g21/afriedle/work/ompibuild/
>>>> openmpi-1.2.2/ompi/tools/ompi_info'
>>>> make[1]: *** [all-recursive] Error 1
>>>>
>>>> Google didn't turn anything up. Strange thing is, gcc 3.4.5 works
>>>> just fine on this system. I'm using this to build:
>>>>
>>>> export CC=gcc
>>>> export CXX=g++
>>>> export F77=g77
>>>> export FC=pathf90
>>>> export CFLAGS="-g -O2"
>>>> export CXXFLAGS="-g -O2"
>>>> export FFLAGS="-fno-second-underscore -g -O2"
>>>> export FCFLAGS="-fno-second-underscore -g -O2"
>>>> export PREFIX=$ROOT/gnudbg
>>>>
>>>> ./configure --prefix=$PREFIX --enable-debug --enable-mpi-f77 --
>>>> enable-mpi-f90 --with-openib=/usr
>>>>
>>>> I've attached the config.log.. any ideas?
>>>>
>>>> Andrew
>>>> <config.log.bz2>
>>>> <mime-attachment.txt>
>>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>