Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Tim Prins (tprins_at_[hidden])
Date: 2007-06-02 08:16:49


Hi Daniel,

I am able to replicate your problem on Mandriva 2007.1, however I'm not sure
what is going on.

I was able to build the tarball just fine though, so you may try that.

Tim

On Friday 01 June 2007 12:32:54 pm Daniel Pfenniger wrote:
> Hello,
>
> version 1.2.2 refuses to compile on Mandriva 2007.1:
> (more details are in the attached lg files)
> ...
>
> make[2]: Entering directory `/usr/src/rpm/BUILD/openmpi-1.2.2/opal/asm'
> depbase=`echo asm.lo | sed 's|[^/]*$|.deps/&|;s|\.lo$||'`; \
> if /bin/sh ../../libtool --tag=CC --mode=compile gcc
> -DHAVE_CONFIG_H -I. -I. -I../../opal/include -I../../orte/include
> -I../../ompi/include -I../../ompi
> /include -I../.. -O3 -DNDEBUG -finline-functions -fno-strict-aliasing
> -pthr ead -MT asm.lo -MD -MP -MF "$depbase.Tpo" -c -o asm.lo asm.c; \ then
> mv -f "$depbase.Tpo" "$depbase.Plo"; else rm -f "$depbase.Tpo"; exi t 1; fi
> ../../libtool: line 813: X--tag=CC: command not found
> ../../libtool: line 846: libtool: ignoring unknown tag : command not found
> ../../libtool: line 813: X--mode=compile: command not found
> ../../libtool: line 979: *** Warning: inferring the mode of operation is
> depreca ted.: command not found
> ../../libtool: line 980: *** Future versions of Libtool will require
> --mode=MODE be specified.: command not found ../../libtool: line 1123:
> Xgcc: command not found
> ../../libtool: line 1123: X-DHAVE_CONFIG_H: command not found
> ../../libtool: line 1123: X-I.: command not found
> ../../libtool: line 1123: X-I.: command not found
> ../../libtool: line 1123: X-I../../opal/include: No such file or directory
> ../../libtool: line 1123: X-I../../orte/include: No such file or directory
> ../../libtool: line 1123: X-I../../ompi/include: No such file or directory
> ../../libtool: line 1123: X-I../../ompi/include: No such file or directory
> ../../libtool: line 1123: X-I../..: No such file or directory
> ../../libtool: line 1123: X-O3: command not found
> ../../libtool: line 1123: X-DNDEBUG: command not found
> ../../libtool: line 1123: X-finline-functions: command not found
> ../../libtool: line 1123: X-fno-strict-aliasing: command not found
> ../../libtool: line 1123: X-pthread: command not found
> ../../libtool: line 1123: X-MT: command not found
> ../../libtool: line 1123: Xasm.lo: command not found
> ../../libtool: line 1123: X-MD: command not found
> ../../libtool: line 1123: X-MP: command not found
> ../../libtool: line 1123: X-MF: command not found
> ../../libtool: line 1123: X.deps/asm.Tpo: No such file or directory
> ../../libtool: line 1123: X-c: command not found
> ../../libtool: line 1175: Xasm.lo: command not found
> ../../libtool: line 1180: libtool: compile: cannot determine name of
> library obj ect from `': command not found make[2]: *** [asm.lo] Error 1
> make[2]: Leaving directory `/usr/src/rpm/BUILD/openmpi-1.2.2/opal/asm'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/rpm/BUILD/openmpi-1.2.2/opal'
> make: *** [all-recursive] Error 1
> [root openmpi-1.2.2]#