Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-05-24 17:31:17


It looks like this is a feature, not a bug. :-)

ompi_info is specifically clearing out the environment variables
corresponding to framework names (e.g., "btl"). If ompi_info didn't
do that, the OMPI core would only load the components that you have
specified in the environment and not show you all available
components. In your example, you'd only be able to see [the
parameters for] the tcp and self BTL components.

So what you're seeing is an artifact of how OMPI loads components;
ompi_info is deliberately overriding your environment setting so that
all components can be loaded.

Probably a more obvious thing to do would simply be to a) whack the
environment so that we load all components, b) load the components,
and then c) restore the environment so that you can see the value
that you expected.

https://svn.open-mpi.org/trac/ompi/changeset/14771 puts this behavior
on the OMPI development trunk.

On May 24, 2007, at 1:07 PM, Josh England wrote:

> Hi all,
>
> Found a bug maybe:
>
> I'm setting the following environment variables:
> OMPI_MCA_btl="tcp,self"
> OMPI_MCA_btl_tcp_if_include="eth2"
> OMPI_MCA_btl_tcp_if_exclude="eth0"
>
> However, when I run 'ompi_info --param btl tcp' I see (among other
> things):
> MCA btl: parameter "btl" (current value: <none>)
> MCA btl: parameter "btl_tcp_if_include" (current value: "eth2")
> MCA btl: parameter "btl_tcp_if_exclude" (current value: "eth0")
>
> ^^^ The btl setting in my environment does not seem to be getting set
> properly. This looks like a bug, but I might just be doing something
> wrong.
>
> -JE
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems