Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Josh England (jjengla_at_[hidden])
Date: 2007-05-24 13:07:05


Hi all,

Found a bug maybe:

I'm setting the following environment variables:
OMPI_MCA_btl="tcp,self"
OMPI_MCA_btl_tcp_if_include="eth2"
OMPI_MCA_btl_tcp_if_exclude="eth0"

However, when I run 'ompi_info --param btl tcp' I see (among other
things):
MCA btl: parameter "btl" (current value: <none>)
MCA btl: parameter "btl_tcp_if_include" (current value: "eth2")
MCA btl: parameter "btl_tcp_if_exclude" (current value: "eth0")

^^^ The btl setting in my environment does not seem to be getting set
properly. This looks like a bug, but I might just be doing something
wrong.

-JE