Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-05-18 20:20:43


On May 18, 2007, at 5:01 PM, Steven Truong wrote:

> So my shell might have exited when it detect that I ran
> non-interactively. But then again, how this parameter
> MCA pls: parameter "pls_rsh_agent" (current value: "ssh :rsh")
> affect my outcome?

It means that OMPI is going to first look for ssh, and if it doesn't
find it, it will use rsh.

> How am I going to set PATH and LD_LIBRARY_PATH to
> be like those in .bash_profile in my Torque job files?

Err... I don't know. It depends on what is set in your Torque job
files and how it is set.

Normally, Torque jobs copy the environment from where you invoked
qsub. So if you have PATH / LD_LIBRARY_PATH set properly in the
shell where you invoke qsub, it should automatically propagate out to
where your script runs.

> Could you give me some tips here?
>
> [struong_at_neptune ~]$ cat .bash_profile | grep -v ^#

According to the FAQ entry that I cited to you, you need to set the
PATH / LD_LIBRARY_PATH in .bashrc, not .bash_profile.

http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path

> [struong_at_neptune ~]$ ssh node07 which orted
> which: no orted in (/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin)

If you're not setting the PATH / LD_LIBRARY_PATH in your .bashrc,
this is to be expected.

> [struong_at_neptune ~]$ /usr/local/openmpi-1.2.1/bin/mpirun --host node07
> node07 hostname

Note that you listed "node07" twice. Hence, mpirun thought that the
2nd "node07" was your executable name, resulting in the predictable
error:

> ----------------------------------------------------------------------
> --
> Failed to find the following executable:
>
> Host: node07.nanostellar.com
> Executable: node07
>
> Cannot continue.
> ----------------------------------------------------------------------
> --

Because there is no executable named "node07".

-- 
Jeff Squyres
Cisco Systems