Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-05-18 19:47:21


On May 18, 2007, at 4:38 PM, Steven Truong wrote:

> [struong_at_neptune 4cpu4npar10nsim]$ mpirun --mca btl tcp,self -np 1
> --host node07 hostname
> bash: orted: command not found

As you noted later in your mail, this is the key problem: orted is
not found on the remote node.

Notice that you are currently using the rsh launcher, not the Torque
launcher (presumably because you are not inside a Torque job). What
you want to check is:

rsh node07 which orted

(or use ssh -- whatever is correct for your cluster)

I suspect that orted will not be found, and that you'll need to
modify your shell startup files to set PATH / LD_LIBRARY_PATH
properly. Note that some shell startup files will exit early if they
detect that they are running on a non-interactive login. See http://
www.open-mpi.org/faq/?category=running#adding-ompi-to-path for more
details.

Alternatively, you can simply use the absolute pathname to mpirun,
which Open MPI will interpret to mean that you want OMPI to set the
PATH/LD_LIBRARY_PATH on the remote node for you. Something like this:

/usr/local/openmpi-1.2.1/bin/mpirun --host node07 hostname

(note that the "btl" MCA parameter is only relevant for MPI executables)

-- 
Jeff Squyres
Cisco Systems