Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Brian Barrett (bbarrett_at_[hidden])
Date: 2007-05-14 17:50:10


On May 13, 2007, at 6:23 AM, Bert Wesarg wrote:

>>
>> Even better: is there a patch available to fix this in the 1.2.1
>> tarball, so that
>> I can set the full path again with CC?
> The patch is quite trivial, but requires a rebuild of the build
> system
> (autoheader, autoconf, automake,...)
>
> see here:
> https://svn.open-mpi.org/trac/ompi/changeset/14610
>
> but you can try to hack the current configure script, just by
> search for
> the affected line

As Bert said, the patch to fix the bug causes a bunch of files to
rebuild using tools you probably don't want to bother installing.
The easiest solution for now is to use the 1.2.2rc1 pre-release,
available on the download page:

    http://www.open-mpi.org/software/ompi/v1.2/

Fixes a bunch of small issues found in the 1.2 and 1.2.1 releases,
including the CC with a path in it bug that you've stumbled upon.

Brian

-- 
   Brian W. Barrett
   Open MPI Team, CCS-1
   Los Alamos National Laboratory