Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-05-10 21:53:41


Check out the FAQ:

http://www.lam-mpi.org/faq/category6.php3

On May 10, 2007, at 9:50 PM, Code Master wrote:

>
>
> On 5/11/07, Tim Prins <tprins_at_[hidden]> wrote: On Thursday 10
> May 2007 07:19 pm, Code Master wrote:
> > I am a newbie in openmpi. I have just compiled a program with -g
> -pg (an
> > mpi program with a listener thread, which all MPI calls except
> > initialization and MPI_Finalize are placed within) and I run
> it. However
> > it crashes and I can't find any core dump, even I set the core
> dump max
> > size to 100000 by
> >
> > ulimit -c 100000
> You probably need to set the ulimit in your .bashrc to get a core
> dump, since
> processes are (by default) started via ssh.
>
> >
> > Signal:11 info.si_errno:0(Success) si_code:1(SEGV_MAPERR)
> > Failing at addr:(nil)
> > [0] func:raytrace [0x8185581]
> > [1] func:[0xffffe440]
> > [2] func:raytrace [0x8056736]
> > [3] func:/lib/tls/libpthread.so.0 [0x40063b63]
> > [4] func:/lib/tls/libc.so.6(__clone+0x5a) [0x4014618a]
> > *** End of error message ***
> > I tried to use gdb and I ran:
> > gdb mpirun
> >
> > run --hostfile ../hostfile n 16 raytrace -finputs/car.env
> >
> > when I type
> >
> > backtrace
> >
> >
> > after it crashes, it just said "no stack"
> This is because you are debugging mpirun, and not your application.
> Mpirun
> runs to completion successfully, but it is your program which is
> crashing.
>
> That's great, but how can I debug my program under mpi?
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems