Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-05-10 20:07:19


Brian --

Didn't you add something to fix exactly this problem recently? I
have a dim recollection of seeing a commit go by about this...?

(I advised Steve in IM to use --disable-ipv6 in the meantime)

On May 10, 2007, at 1:25 PM, Steve Wise wrote:

> I'm trying to run a job specifically over tcp and the eth1 interface.
> It seems to be barfing on trying to listen via ipv6. I don't want
> ipv6.
> How can I disable it?
>
> Here's my mpirun line:
>
> [root_at_vic12-10g ~]# mpirun --n 2 --host vic12,vic20 --mca btl
> self,tcp -mca btl_tcp_if_include eth1 /root/IMB_2.3/src/IMB-MPI1
> sendrecv
> [vic12][0,1,0][btl_tcp_component.c:
> 489:mca_btl_tcp_component_create_listen] socket() failed: Address
> family not supported by protocol (97)
> [vic12-10g:15771] mca_btl_tcp_component: IPv6 listening socket failed
> [vic20][0,1,1][btl_tcp_component.c:
> 489:mca_btl_tcp_component_create_listen] socket() failed: Address
> family not supported by protocol (97)
> [vic20-10g:23977] mca_btl_tcp_component: IPv6 listening socket failed
>
>
> Thanks,
>
> Steve.
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems