Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (bbarrett_at_[hidden])
Date: 2007-05-07 15:21:34


This was a regression in Open MPI 1.2.1. We improperly handle the
situation where CC has a path in it. We will have this fixed in Open
MPI 1.2.2. For now, your options are to use Open MPI 1.2 or specify
a $CC without a path, such as CC=icc, and make sure $PATH is set
properly.

Brian

On May 7, 2007, at 1:12 PM, Paul Van Allsburg wrote:

> I just completed the install of release 1.2.1 and I get an error
> attempting to compile with mpicc.
>
> The install was done with:
>
> source /opt/intel/fce/9.1.045/bin/ifortvars.sh
> source /opt/intel/cce/9.1.049/bin/iccvars.sh
> ./configure --prefix=/usr/local/openmpi-1.2.1_intel \
> --with-tm=/usr/local \
> --enable-static \
> --disable-shared \
> CC=/opt/intel/cce/9.1.049/bin/icc \
> CXX=/opt/intel/cce/9.1.049/bin/icpc \
> FC=/opt/intel/fce/9.1.045/bin/ifort
> make all install
>
>
> I tried to compile my hello program with
>
> $ source /opt/intel/fce/9.1.045/bin/ifortvars.sh
> $ source /opt/intel/cce/9.1.049/bin/iccvars.sh
> $ PATH="/usr/local/openmpi-1.2.1_intel/bin:$PATH";export PATH
> $ mpicc hello.c -o hello -g
> ld: dummy: No such file: No such file or directory
>
>
> I installed 1.2 exactly the same and it works fine.
>
> Any suggestions? Thanks!
> Paul
>
> --
> Paul Van Allsburg
> Computational Science & Modeling Facilitator
> Natural Sciences Division, Hope College
> 35 East 12th Street
> Holland, Michigan 49423
> 616-395-7292
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users