Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Harald Servat (harald_at_[hidden])
Date: 2007-05-02 11:37:07


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

  I'm using the PERUSE API from OpenMPI in order to know when messages
arrive. I've executed some simple tests in three different machines
(FreeBSD/x86 1cpu, SGI Altix/IA64 128cpus, Linux/ppc 4cpus) always using
OpenMPI 1.2 and I see that sometimes I'm loosing such MSG_ARRIVED events.

  For example, from the 20 runs that I do, 5 at least, do not show that
every task but the root prints "total_msg_arrived = 1", instead they
print some "total_msg_arrived = 0".

  George Bosilca told me that this never should happen due to the code
implementation, but it's happening to me. So I'm wondering why is this
happening in all the machines. Any idea?

  I run the configure just with the --prefix option and with
- --enable-peruse. Shall I add any other option?

Regards,
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (FreeBSD)

iD8DBQFGOLAjwMPeuqUCg9wRAiprAJ9N6fCJmQlKwvHCwx+zHj8vAp6t6QCfbOsu
uasthRat55g07BccQ8bBuEk=
=25PB
-----END PGP SIGNATURE-----