Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2007-05-01 09:56:16


Brian --

Is this due to missing assembly functionality for Alpha platforms in
opal? (I'm not sure why it would work with dynamic if that were the
case, though...)

On May 1, 2007, at 6:41 AM, Rob wrote:

> Hi all,
>
> I use gcc-4.1.3 (gcc/g++/gfortran) with openmpi-1.2.1 on an Alpha
> system
> with Linux CentOS 4.4.
>
> The "--enable-static" configure option causes the make to end with
> error.
> Without this configure option, there is no problem with the make.
>
> Note that I need the "-mfp-trap-mode=su" compiler flag with this alpha
> system, to avoid a runtime sigsegv abort. This is what I have done:
>
> $ ./configure CPP=/opt/gcc/bin/cpp \
> CC=/opt/gcc/bin/gcc CFLAGS=-mfp-trap-mode=su \
> CXX=/opt/gcc/bin/g++ CXXFLAGS=-mfp-trap-mode=su \
> F77=/opt/gcc/bin/gfortran FFLAGS=-mfp-trap-mode=su \
> FC=/opt/gcc/bin/gfortran FCFLAGS=-mfp-trap-mode=su \
> --with-wrapper-cflags=-mfp-trap-mode=su \
> --with-wrapper-cxxflags=-mfp-trap-mode=su \
> --with-wrapper-fflags=-mfp-trap-mode=su \
> --with-wrapper-fcflags=mfp-trap-mode=su \
> --enable-static --prefix=/opt/openmpi
> [ ...snip... ]
> $ make all
> [ ...snip... ]
> if /opt/gcc/bin/g++ -DHAVE_CONFIG_H -I. -I. -I../../../opal/include
> -I../../../orte/include -I../../../ompi/include -I../../../ompi/
> include -DOMPI_CONFIGURE_USER="\"rob\"" -
> DOMPI_CONFIGURE_HOST="\"alpha\"" -DOMPI_CONFIGURE_DATE="\"Tue May
> 1 21:48:43 KST 2007\"" -DOMPI_BUILD_USER="\"$USER\"" -
> DOMPI_BUILD_HOST="\"`hostname`\"" -DOMPI_BUILD_DATE="\"`date`\"" -
> DOMPI_BUILD_CFLAGS="\"-O3 -DNDEBUG -mfp-trap-mode=su -finline-
> functions -fno-strict-aliasing -pthread\"" -
> DOMPI_BUILD_CPPFLAGS="\"-I../../.. \"" -DOMPI_BUILD_CXXFLAGS="\"-
> O3 -DNDEBUG -mfp-trap-mode=su -finline-functions -pthread\"" -
> DOMPI_BUILD_CXXCPPFLAGS="\"-I../../.. \"" -DOMPI_BUILD_FFLAGS="\"-
> mfp-trap-mode=su\"" -DOMPI_BUILD_FCFLAGS="\"-mfp-trap-mode=su\"" -
> DOMPI_BUILD_LDFLAGS="\"-export-dynamic \"" -DOMPI_BUILD_LIBS="\"-
> lnsl -lutil -lm \"" -DOMPI_CC_ABSOLUTE="\"/opt/gcc/bin/gcc\"" -
> DOMPI_CXX_ABSOLUTE="\"/opt/gcc/bin/g++\"" -DOMPI_F77_ABSOLUTE="\"/
> opt/gcc/bin/gfortran\"" -DOMPI_F90_ABSOLUTE="\"/opt/gcc/bin/gfortran
> \"" -DOMPI_F90_BUILD_SIZE="\"small\"" -I../../.. -O3 -DNDEBUG -
> mfp-trap-mode=su -finline-functions -pthread -MT version.o -MD -MP -
> MF "$depbase.Tpo" -c -o version.o version.cc; \
> then mv -f "$depbase.Tpo" "$depbase.Po"; else rm -f "$depbase.Tpo";
> exit 1; fi
> /bin/sh ../../../libtool --tag=CXX --mode=link /opt/gcc/bin/g++ -
> O3 -DNDEBUG -mfp-trap-mode=su -finline-functions -pthread -export-
> dynamic -o ompi_info components.o ompi_info.o output.o param.o
> version.o ../../../ompi/libmpi.la -lnsl -lutil -lm
> libtool: link: /opt/gcc/bin/g++ -O3 -DNDEBUG -mfp-trap-mode=su -
> finline-functions -pthread -o .libs/ompi_info components.o
> ompi_info.o output.o param.o version.o -Wl,--export-
> dynamic ../../../ompi/.libs/libmpi.so -libverbs -lrt /home/lahaye/
> Software/openmpi-1.2.1/orte/.libs/libopen-rte.so -pthread /home/
> lahaye/Software/openmpi-1.2.1/opal/.libs/libopen-pal.so -ldl -lnsl -
> lutil -lm -Wl,-rpath -Wl,/opt/openmpi/lib
> ../../../ompi/.libs/libmpi.so: undefined reference to
> `opal_sys_timer_get_cycles'
> collect2: ld returned 1 exit status
> make[2]: *** [ompi_info] Error 1
> make[2]: Leaving directory `/home/lahaye/Software/openmpi-1.2.1/
> ompi/tools/ompi_info'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/lahaye/Software/openmpi-1.2.1/ompi'
> make: *** [all-recursive] Error 1
>
>
>
> Any idea why this goes wrong?
>
> Once again, when I remove the "--enable-static" in the configure
> line, then
> all goes well....
> But I need the static libraries for compiling Blacs/ScaLapack.
>
> Thanks,
> Rob.
>
>
> Ahhh...imagining that irresistible "new car" smell?
> Check out new cars at Yahoo! Autos.
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems